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Trademarks Used in this Manual

Trademarks Used in this Manual

Black Box and the Double Diamond logo are registered trademarks, and 
ServSwitch is a trademark, of BB Technologies, Inc.

Mac is a registered trademark of Apple Computer, Inc.

IBM is a registered trademark of International Business Machines Corporation.

Java is a registered trademark of Oracle Corporation.

TOSLINK is a registered trademark of Toshiba Corporation.

Any other trademarks mentioned in this manual are acknowledged to be  
the property of the trademark owners.

NOTE: �The ServSwitch DKM FX and the ServSwitch DKM FX Compact function in 
similar ways. The difference between them is described in the table below.

Table 1. ServSwitch DKM FX and DKM FX Compact comparison.

ServSwitch DKM FX Compact ServSwitch DKM FX

Number of Ports 8-, 16-, 32-, 48-, 64-, 80-port options 48-, 80-, 160-, 288-port options

Type of Ports CATx/Fiber CATx/fiber I/O ports dependent on I/O card

Form Factor Small form factor (1/2U) Large form factor (4U+)

Modular or Not Not modular Modular

Disclaimer

Black Box Network Services shall not be liable for damages of any kind, including, 
but not limited to, punitive, consequential or cost of cover damages, resulting 
from any errors in the product information or specifications set forth in this docu-
ment and Black Box Network Services may revise this document at any time with-
out notice.
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FCC and IC RFI Statements/NOM Statement

FEDERAL COMMUNICATIONS COMMISSION AND 
INDUSTRY CANADA RADIO FREQUENCY INTERFERENCE STATEMENTS

This equipment generates, uses, and can radiate radio-frequency energy,  
and if not installed and used properly, that is, in strict accordance with the  
manufacturer’s instructions, may cause interference to radio communication.  
It has been tested and found to comply with the limits for a Class A computing 
device in accordance with the specifications in Subpart B of Part 15 of FCC rules, 
which are designed to provide reasonable protection against such interference 
when the equipment is operated in a commercial environment. Operation of  
this equipment in a residential area is likely to cause interference, in which case 
the user at his own expense will be required to take whatever measures may be 
necessary to correct the interference.

Changes or modifications not expressly approved by the party responsible  
for compliance could void the user’s authority to operate the equipment.

This digital apparatus does not exceed the Class A limits for radio noise  
emission from digital apparatus set out in the Radio Interference Regulation  
of Industry Canada.

Le présent appareil numérique n’émet pas de bruits radioélectriques dépassant les 
limites applicables aux appareils numériques de la classe A prescrites dans le 
Règlement sur le brouillage radioélectrique publié par Industrie Canada.

Normas Oficiales Mexicanas (NOM) 
Electrical Safety Statement

INSTRUCCIONES DE SEGURIDAD

1.�	Todas las instrucciones de seguridad y operación deberán ser leídas antes 		
de que el aparato eléctrico sea operado.

2. ��Las instrucciones de seguridad y operación deberán ser guardadas para 	
referencia futura.

3. �Todas las advertencias en el aparato eléctrico y en sus instrucciones de 		
operación deben ser respetadas.
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	 4.	 Todas las instrucciones de operación y uso deben ser seguidas.

	 5.	 El aparato eléctrico no deberá ser usado cerca del agua—por ejemplo,  
		  cerca de la tina de baño, lavabo, sótano mojado o cerca de una alberca, 		
		  etc.

	 6.	 El aparato eléctrico debe ser usado únicamente con carritos o pedestales 		
		  que sean recomendados por el fabricante. 

	 7.	 El aparato eléctrico debe ser montado a la pared o al techo sólo como sea 	
		  recomendado por el fabricante.

	 8.	 Servicio—El usuario no debe intentar dar servicio al equipo eléctrico más allá 	
		  lo descrito en las instrucciones de operación. Todo otro servicio deberá ser 	
		  referido a personal de servicio calificado. 

	 9.	 El aparato eléctrico debe ser situado de tal manera que su posición no 		
		  interfiera su uso. La colocación del aparato eléctrico sobre una cama, sofá, 	
		  alfombra o superficie similar puede bloquea la ventilación, no se debe 		
		  colocar en libreros o gabinetes que impidan el flujo de aire por los orificios 	
		  de ventilación.

	 10.	 El equipo eléctrico deber ser situado fuera del alcance de fuentes de calor 	
		  como radiadores, registros de calor, estufas u otros aparatos (incluyendo 		
		  amplificadores) que producen calor.

	 11.	 El aparato eléctrico deberá ser connectado a una fuente de poder sólo del 	
		  tipo descrito en el instructivo de operación, o como se indique en el 		
		  aparato.

	 12.	 Precaución debe ser tomada de tal manera que la tierra fisica y la 		
		  polarización del equipo no sea eliminada.

	 13.	 Los cables de la fuente de poder deben ser guiados de tal manera que no 	
		  sean pisados ni pellizcados por objetos colocados sobre o contra ellos, 		
		  poniendo particular atención a los contactos y receptáculos donde salen  
		  del aparato.

	 14.	 El equipo eléctrico debe ser limpiado únicamente de acuerdo a las 		
		  recomendaciones del fabricante.

	 15.	 En caso de existir, una antena externa deberá ser localizada lejos de las 		
		  lineas de energia.

	 16.	 El cable de corriente deberá ser desconectado del cuando el equipo no sea 	
		  usado por un largo periodo de tiempo.
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	 17.	 Cuidado debe ser tomado de tal manera que objectos liquidos no sean 		
		  derramados sobre la cubierta u orificios de ventilación.

	 18.	 Servicio por personal calificado deberá ser provisto cuando:

		  A: El cable de poder o el contacto ha sido dañado; u

		  B: Objectos han caído o líquido ha sido derramado dentro del aparato; o

		  C: El aparato ha sido expuesto a la lluvia; o

		  D: �El aparato parece no operar normalmente o muestra un cambio en su 		
desempeño; o

		  E: El aparato ha sido tirado o su cubierta ha sido dañada.
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Safety Instructions

Safety Instructions
For reliable and safe long-term operation of your ServSwitch DKM FX, follow these 
guidelines:

Installation 

• Only use the device according to this user manual.

• Only use in dry, indoor environments.

• �The ServSwitch DKM FX and the power supply units can get warm. Don’t put them 
in an enclosed space without any airflow.

• Do not obscure ventilation holes.

• �Only use power supplies originally supplied with the product or manufacturer-
approved replacements. Do not use a power supply if it appears to be defective or 
has a damaged case.

• �Connect all power supplies to grounded outlets. In each case, make sure that the 
ground connection is maintained from the outlet socket to the power supply’s AC 
power input.

• �Do not connect the link interface to any other equipment, particularly network or 
telecommunications equipment.

• �Only connect devices to the serial interface that are sufficiently secured against 
short circuits and false voltages at the serial interface.

• �To disconnect the switch from the power supply, remove the power cords of all 
power supply units that are in use or set the power switch (if available) to the OFF 
position.

• Take any required ESD precautions.

Repair
• Do not attempt to open or repair a power supply unit.

• �Do not attempt to open or repair the ServSwitch DKM FX. There are no  
user-serviceable parts inside.

• �Contact Black Box Technical Support at 724-746-5500 or info@blackbox.com  
if there is a fault.
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Chapter 1: Specifications

1. Specifications

1.1 Interfaces

1.1.1 DVI-D Single Link
The video interface supports the DVI-D protocol. All signals that comply with 
DVI-D single-link standard can be transmitted. This includes, for example, monitor 
resolutions such as 1920 x 1200 @ 60 Hz, Full HD (1080p), or 2K HD (up to 2048 
x 1152). Data rate is limited to 165 MPixel/s.

1.1.2 USB HID
Devices with USB HID interface support a maximum of two devices with  
USB HID protocol. Each USB HID port provides a maximum current of 100 mA.

Keyboard

The DKM FX or FXC is compatible with most USB keyboards. Certain keyboards 
with additional functions may require custom firmware to operate. Keyboards with 
an integral USB Hub (Mac® keyboards, for example) are also supported, but you 
cannot use more than two active USB HID devices on the DVI and USB HID cards.

Mouse

Compatible with most 2-button, 3-button, and scroll mice.

Other USB HID devices

The proprietary USB emulation also supports certain other USB HID devices, such 
as specific touchscreens, graphics tablets, bar-code scanners, or special keyboards. 
Support cannot be guaranteed, however, for every USB HID device.

NOTE: �Only two USB HID devices are supported concurrently, such as keyboard 
and mouse or keyboard and touchscreen. A hub is allowed, but it does not 
increase the number of HID devices allowed.

To support other USB “non-HID” devices, such as scanners, Web cams or memory 
devices, choose our devices with transparent USB support.

1.1.3 RJ-45 (Network)
CATx device communication requires a 1000BASE-T connection. Pin the cable 
according to EIA/TIA-568-B (1000BASE-T) standard with RJ-45 connectors at both 
ends. All four wire pairs are used in both directions. The cabling is suitable for  
full-duplex operation. For the cable connection to a source (computer, CPU), use a 
cross-pinned network cable.
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�1.1.4 RS-232 (Serial)

The communication takes place with a transmission speed of up to 115.2 kbps, 
regardless of the file format, eight data bits and a stop bit, but without a parity 
bit. Limited hardware handshake (DSR) is possible.

1.1.5 RJ-45 (Interconnect)
CATx device communication requires a 1000BASE-T connection.

Connector wiring must comply with EIA/TIA-568-B (1000BASE-T), with RJ-45 
connectors at both ends. All four wire pairs are used.

1.1.6 Fiber SFP Type LC (Interconnect)
Fiber device communication is performed via Gigabit SFPs connected to suitable 
fibers fitted with LC connectors (see Section 1.2.2).

NOTE: �The correct function of the device can only be guaranteed with SFPs  
provided by Black Box.

CAUTION: �SFP modules can be damaged by electrostatic discharge (ESD). Follow 
ESD handling precautions.

1.1.7 SDI (Interconnect)
SDI device communication requires a mini coax connection with mini BNC  
connectors or 3G SFPs with transmission speeds of 0.360 Gbps (SD-SDI, SMPTE 
259M), 1.485 Gbps (HD-SDI, SMPTE 292M), and 2.970 Gbps (3G SDI).

1.2 Interconnect Cable
1.2.1 CATx
NOTE: �A point-to-point connection is required. Operation with several patch 

cables is possible. Routing over an active network component, such as an 
Ethernet hub or router is not allowed. 
• Avoid routing CATx cables along power cables. 
• �If the site has three-phase AC power, make sure that the CPU Unit and 

CON Unit are on the same phase.

NOTE: �To maintain regulatory EMC compliance, use correctly installed shielded 
CATx cable throughout the interconnection link.

NOTE: �To maintain regulatory EMC compliance, all CATx cables need to carry  
ferrites on both cable ends close to the device.

Type of Interconnect Cable

The ServSwitch DKM FX requires interconnect cabling specified for Gigabit 
Ethernet (1000BASE-T). Use solid-core (24 AWG), shielded, CAT5e (or better) 
cable.
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Table 1-1. CATx interconnect cable.

Cable Type Description

CATx solid-core 24 AWG cable
This S/UTP (CAT5e) cable confoms to EIA/TIA-568-B.  
Uses four pairs of 24 AWG wires. Connects according  
to EIA/TIA-568-B (1000BASE-T).

CATx solid-core 26/8 AWG cable
This S/UTP (CAT5e) cable confoms to EIA/TIA-568-B.  
Uses four pairs of 26/8 AWG wires. Connects according  
to EIA/TIA-568-B (1000BASE-T).

NOTE: �You can use use type 26/8 AWG flexible cables (patch cables), but the 
maximum possible extension distance is cut in half.

Table 1-2. Maximum acceptable cable length.

Cable Type Distance

CATx 24 AWG solid conductor cable 400 ft. (140 m)

CATx 26/8 AWG stranded conductor cable 200 ft. (70 m)

1.2.2 Fiber

NOTE: ��A point-to-point connection is necessary. Operation with multiple patch 
panels is allowed. Routing over active network components, such as 
Ethernet hubs, matrices, or routers, is not allowed.

Type of Interconnect Cable

Table 1-3. Fiber interconnect cable.

Cable Type Description

Single-mode, 9-µm
• Two fibers, 9-µm 
• In-house patch cable (EFN092)

Multimode 50-µm
• Two fibers, 50-µm 
• In-house patch cable (EFN6020)

Multimode 62.5-µm
• Two fibers, 62.5-µm 
• In-house patch cable (EFN116-LCLC)

NOTE: �Only use single-mode cables for fiber connections that are based on 3G 
SFPs.
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Table 1-4. Maximum acceptable fiber cable length.

Cable Type Distance

Single-mode 9-µm 32,800 ft. (10,000 m)

Multimode 50-µm (OM3) 3280 ft. (1000 m)

Multimode 50-µm 1300 ft. (400 m)

Multimode 62.5µm 650 ft. (200 m)

NOTE:  �If you use single-mode SFPs with multimode fiber optic cable, you can 
double the maximum acceptable cable length.

Type of Connector

The fiber cable uses LC connectors.

1.2.3 Coaxial
NOTE: A point-to-point connection is necessary.

Table 1-5. Coaxial interconnect cable.
Cable Type Description

Mini coaxial cable, 18 AWG
RG-6 
Impedance: 75 ohms

Table 1-6. Maximum acceptable coaxial cable length.

Bandwidth Distance

0.270 Gbps 1312 ft. (400 m)

1.485 Gbps 459 ft. (140 m)

2.970 Gbps 394 ft. (120 m)

Type of Connector

The coaxial cable uses mini BNC connectors.
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1.3 Connector Pinouts
1.3.1 CPU Board

Figure 1-1. DVI-D single-link connector.

Table 1-7. DVI-D single-link connector pinout. 

Pin Signal Pin Signal Pin Signal

1 T.M.D.S. data 2- 9 T.M.D.S. data 1- 17 T.M.D.S. data 0-

2 T.M.D.S. data 2+ 10 T.M.D.S. data 1+ 18 T.M.D.S. data 0+

3 T.M.D.S. data 2 GND 11 T.M.D.S. data 1 GND 19 T.M.D.S. data 0 GND

4 Not connnected 12 Not connected 20 Not connected

5 Not connected 13 Not connected 21 Not connected

6 DDC input (SCL) 14 +5 VDC high impedance 22 T.M.D.S. GND

7 DDC output (SDA) 15 GND 23 T.M.D.S. clock+

8 Internal use 16 Hot plug recognition 24 T.M.D.S. clock-

C1 Internal use — — C3 Internal use

C2 Not connected C5 GND C4 Internal use

Table 1-8. USB Type A connector.

Picture Pin Signal Color

1 VCC (+5 VDC) Red

2 Data - White

3 Data + Green

4 GND Black
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Table 1-9. DB9 (serial) connector.

Picture Pin Signal Color Signal

9 Not connected 4 DTR

8 CTS 3 TxD

7 RTS 2 RxD

6 DSR 1 Not connected

5 GND — —

Table 1-10. RJ-45 connector.

Picture Pin Signal Color Signal

1 D1+ 5 Not connected

2 D1- 6 D2-

3 D2+ 7 Not connected

4 Not connected 8 Not connected

1.3.2 I/O Board CATx

Table 1-11. RJ-45 CATx connector.

Picture Pin Signal Color Signal

1 D1+ 5 D3-

2 D1- 6 D2-

3 D2+ 7 D4+

4 D3+ 8 D4-

1.3.3 I/O Board SFP
Table 1-12. LC fiber connector.

Picture Diode Signal

1 Data OUT

2 Data IN
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1.3.4 I/O Board SDI

Table 1-13. BNC connector.

Picture Pin Signal

1 Data In

2 GND

1.4 Power Supply, Environment, Dimensions, and Weight

Power ACXC48, ACXC48F, ACXC32, ACXC32F, ACXC16, ACXC16F:  
   1.4 A, 100–240 VAC, 50–60 Hz internal power supply; 
ACXC80, ACXC80F, ACXC64, ACXC64C, ACXC48F32,  
   ACXC48F16: 2.3 A, 100–240 VAC, 50–60 Hz; 
ACXC80, ACXC80F, ACXC48F32: Max. 125 W; 
ACXC64, ACXC64F, ACXC48F16: Max. 105 W; 
ACXC48, ACXC48F: Max. 90 W; 
ACXC32, ACXC32F: Max. 65 W; 
ACXC16, ACXC16F: Max. 40 W; 
ACXC8, ACXC8F: Max. 13 W; 
ACX048: 5 A, 94 W max. without I/O boards;  
ACX080, ACX080-PS: 5 A, 99 W max. without I/O boards; 
ACX160, ACX160-PS: 9 A, 188 W max. without I/O boards; 
ACX288, ACX288-PS: 12 A, 202 W max. without I/O boards; 
I/O boards (ACXI08-C, ACXI08-SM, ACXI08-SPF): 13 W max.

Environment Temperature Tolerance:  
   Operating: +41 to +113° F (+5 to +45° C); 
   Storage: -13 to +140° F (-25 to +60° C); 
Relative Humidity: Max. 80%, non-condensing
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Specifications

Dimensions ACX288: 19"H x 22.8"W x 12"D (48.3 x 57.8 x 33 cm), 
  Shipping box: 25.6"H x 26.8"W x 29.9"D (65 x 68 x  
     76 cm); 
ACX160: 19"H x 15.8"W x 12"D (48.3 x 40 x 33 cm), 
  Shipping box: 25.6"H x 26.8"W x 12"D (65 x 68 x 54 cm); 
ACX080: 19"H x 7"W x 9.1"D (64 x 57 x 36 cm), 
  Shipping box: 25.2"H x 22.4"W x 21.3"D (64 x 57 x  
     36 cm); 
ACX048: 19"H x 5.3"W x 9.1"D, 
Shipping box: 25.2" x 22.4"W x 12.4"D (64 x 57 x 23.1 cm); 
ACXC8, ACXC8F: 1.7"H x 8.75"W x 5.75"D (4.3 x 22.3 x  
   14.6 cm); 
ACXC48, ACXC48F, ACXC32, ACXC32F, ACXC16,  
   ACXC16F: 1.7"H x 17.4"W x 16.9"D  
     (4.4 x 44.4 x 42.9 cm); 
ACXC48F16, ACXC48F32: ACXC64, ACXC64F, ACXC80,  
   ACXC80F: 3.4"H x 17.48"W x 16.88"D (8.6 x 44.4 x  
      42.9 cm)

Weight ACX288: 76.2 lb (34.6 kg) fully equipped,  
   Shipping box: 90.6 lb. (41.1 kg); 
ACX160: 60 lb. (26.3 kg) fully equipped, 
   Shipping box: 69.9 lb. (31.7 kg); 
ACX080: 24.5 lb. (11.1 kg) fully equipped, 
   Shipping box: 34.4 lb. (15.6 kg); 
ACX048: 19.6 lb. (8.9 kg), 
   Shipping box: 26.7 lb. (12.1 kg) 
ACXC80, ACXC80F, ACXC48F32: 15.9 lb. (7.2 kg); 
ACXC64, ACXC64F, ACXC48F16: 15.4 lb. (7 kg); 
ACXC48, ACXC48F: 9 lb. (4.1 kg); 
ACXC32, ACXC32F: 8.8 lb. (4 kg); 
ACXC16, ACXC16F: 8.6 lb. (3.9 kg); 
ACXC8, ACXC8F: 1.9 lb. (0.9 kg)
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Specifications

MTBF The mean time between failure (MTBF) in power-on hours 
(POH) is listed here. The estimate is based on the FIT rates of 
the parts included. FIT rates are based on normalized environ-
mental conditions of T = 60°C and activation energy (Ea) of 
0.7 eV. Calculations are based on 90% confidence limit.

We estimate that inside the housing, temperature will be 15°C 
higher than the ambient temperature. Therefore, the MTBF 
calculation refers to an ambient temperature of 45°C. The 
humidity is limited to 60%.

ACX288: 260,000 POH; 
ACX160: 310,000 POH; 
ACX080: 320,000 POH; 
ACX048: 350,000 POH; 
CPU board: 480,000 POH; 
I/O board SFP: 500,000 POH; 
I/O board CATx: 410,000 POH 
DKM FX 288/160 PSU: 200,000 POH; 
DKM FX 80/48 PSU: 130,000 POH; 
ACXC80: Chassis: 90,690; 
   Per fan: 280,000 POH, 
   Per PSU: 238,000; 
ACXC80F: Chassis: 83,350; 
   Per fan: 280,000 POH, 
   Per PSU: 238,000; 
ACXC48F32: Chassis: 87,250; 
   Per fan: 280,000 POH, 
   Per PSU: 238,000; 
ACXC64: Chassis: 97,300; 
Per fan: 280,000 POH, 
   Per PSU: 238,000; 
ACXC64F: Chassis: 92,900; 
   Per fan: 280,000 POH, 
   Per PSU: 238,000; 
ACXC48F16: Chassis: 95,600; 
   Per fan: 280,000 POH, 
   Per PSU: 238,000;
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Specifications

MTBF (continued) ACXC48: Chassis: 140,000; 
   Per fan: 280,000 POH, 
   Per PSU: 295,700; 
ACXC48F: Chassis: 133,400; 
   Per fan: 280,000 POH, 
   Per PSU: 295,700; 
ACXC32: Chassis: 165,300; 
   Per fan: 280,000 POH, 
   Per PSU: 295,700; 
ACXC32F: Chassis: 161,200; 
   Per fan: 280,000 POH, 
   Per PSU: 295,700; 
ACXC16: Chassis: 208,322; 
   Per fan: 280,000 POH, 
   Per PSU: 295,700; 
ACXC16F: Chassis: 206,100; 
   Per fan: 280,000 POH, 
   Per PSU: 295,700; 
ACXC8,ACXC8F: Chassis: 684,700 
   Per fan: 280,000 POH, 
   Per PSU: 309,700
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2. Overview

2.1 Description
2.1.1 Application
The ServSwitch DKM FX is used to establish connections from consoles (monitor, 
keyboard, mouse, and other peripheral devices) to various sources (computer, 
CPU). In a maximum configuration, up to 288 independent ports can be defined 
and switched either as a console or a CPU.

The ServSwitch DKM FX Compact is used to establish connections from consoles 
(monitor, keyboard, mouse, and other peripheral devices) to various sources  
(computer, CPU). In a maximum configuration, up to 8 (using the ACXC8 or 
ACXC8F), 16 (using the ACXC16), 32 (using the ACXC32), 48 (using the 
ACXC48), 48 CATx ports/16 SFP slots (using the ACXC48F16), or 48 CATx 
ports/32 SFP slots (using the ACXC48F32), 64 CATx (using the ACXC64), or 80 
CATx (using the ACXC80) independent ports can be defined and switched either 
as a console or a CPU.

The ServSwitch DKM FX or FXC is mainly specified for the use with extenders that 
are able to transmit video, KVM, and USB 2.0 signals. You can also use it as a  
video-only matrix.

For the connection between the ServSwitch DKM FX or FXC and the peripheral 
devices, such as KVM extenders or video sources, you can use CATx, fiber, or 
coaxial cables, depending on the hardware used.

The ServSwitch DKM FX serves as a repeater. You can place it up to 6.2 miles  
(10 km) from the consoles and 6.2 miles (10 km) from the sources.
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2.1.2 Access Options
You have the following options to access the ServSwitch DKM FX for  
configuration and operation:

Table 2-1. Access options.

Access option Symbol

OSD

Java tool

Serial interface

2.2 System Overview
A ServSwitch DKM FX system consists of a ServSwitch DKM FX or DKM FX 
Compact and, for KVM applications, one or more CPU units/CON units. The 
ServSwitch connects to the CPU units/CON units by interconnect cables (copper 
or fiber) or is connected directly to the video devices when used as a video matrix.

The CPU units connect directly to the sources (computer, CPU), using the included 
cables.

Monitor(s), keyboard, and mouse connect to the CON units.

The ServSwitch DKM FX and the CPU units/CON units communicate over CATx, 
fiber, or coaxial interconnect cables. The ServSwitch DKM FX Compact and the 
CPU units/CON units communicate over CATx or fiber cable.

Figure 2-1 shows the system overview. Table 2-2 describes its components.
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Figure 2-1. System overview.

Table 2-2. System components.

Number Component

1 Computer/Server or Video Source

2 CPU units (Transmiters)

3 Interconnect cable

4 ServSwitch DKM FX or FXC

5 CON units (Receivers)

6 User Station/Console

See Section 3.2 for installation examples.
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2.3 Available Products

Table 2-3. Available products.

Number Description

ServSwitch DKM FX

ACX048 ServSwitch DKM FX 48-port with control card and power supply

ACX080 ServSwitch DKM FX 80-port with control card and power supply

ACX160 ServSwitch DKM FX 160-port with control card and (2) power supplies

ACX288 ServSwitch DKM FX 288-port with control card and (2) power supplies

ServSwitch DKM FX Compact

ACXC8 ServSwitch DKM FX Compact 8-port, CATx

ACXC8F ServSwitch DKM FX Compact 8-port, SFP

ACXC16 ServSwitch DKM FX Compact 16-port, CATx

ACXC16F ServSwitch DKM FX Compact 16-port, 16 SFP slots

ACXC32 ServSwitch DKM FX Compact 32-port, CATx

ACXC32F ServSwitch DKM FX Compact 32-port, 32 SFP slots

ACXC48 ServSwitch DKM FX Compact 48-port, CATx

ACXC48F ServSwitch DKM FX Compact 48-port, 48 SFP slots

ACXC48F16 ServSwitch DKM FX Compact 48 CATX ports, 16 SFP slots

ACXC48F32 ServSwitch DKM FX Compact 48 CATx ports, 32 SFP slots

ACXC64 ServSwitch DKM FX Compact 64-port, CATx

ACXC64F ServSwitch DKM FX Compact 64-port, 64 SFP slots

ACXC80 ServSwitch DKM FX Compact 80-port, CATx

ACXC80F ServSwitch DKM FX Compact 80-port, 80 SFP slots

Accessories

ACX-JAV DKM FX Java Switch and Preset License

ACX-API DKM FX API License for external control, includes ACX-JAV

ACX-SYS DKM FX SNMP Switch and Syslog License

ACX-CAS DKM FX Cascade License

ACX-GSW Multi-Screen Control License

ACXIO8-C 8-port CATx input/output (I/O) module

ACXIO8-SM 8-port single-mode fiber input/output (I/O) module

ACXI08-HS 8-port single-mode fiber SFP input/output (I/O) module 3.125 Gbps

ACXI08-SDI 8-port single-mode SDI fiber input/output (I/O) module

ACXIO8-SFP 8-port single-mode fiber SFP input/output (I/O) module
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Table 2-3 (continued). Available products.

Number Description

Accessories (continued)

ACXI08-G G 8-port universal I/O module that can support third-party SFPs

ACX288-CTL ServSwitch DKM FX controller card

ACXSFPC CATx SFP module

ACXSFPS Single-mode fiber SFP module

ACXSFPHS Single-mode fiber SFP module 3.125 Gbps

ACXSDI-SM-T SDI fiber transmitter card

ACXSDI3G-SM-T HD-SDI/3G-SDI fiber transmitter card

ACXSDI-CX-T SDI CATx transmitter card

ACXSDI3G-CX-T HD-SDI/3G-SDI CATx transmitter card

ACXSDI-SM-R SDI fiber receiver card

ACXSDI3G-SM-R HD-SDI/3G-SDI fiber receiver card

ACXSDI-CX-R SDI CATx receiver card

ACX288-FAN Fan for the 160/288-port chassis

ACX080-FAN Fan for the 80-port chassis

ACX048-FAN Fan for the 48-port chassis

ACX288-PS Power supply for ACX288

ACX160-PS Power supply for ACX160

ACX080-PS Power supply for ACX048 and ACX080

ACX288-FIL Spare Filter Module

ACX080-FIL Spare Filter Module

ACX048-FIL Spare Filter Module

ACX288-BLKP-1S DKM FX 48/80/160/288 blank plate, 1-slot

ACX288-BLKP-2S DKM FX 48/80/160/289 blank plate, 2-slots

ACX288-BLKP-4S DKM FX 48/80/160/290 blank plate, 4-slots

ACX288-BLKP-8S DKM FX 48/80/160/291 blank plate, 8-slots
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2.4 What’s Included

Your package should contain the following items. If anything is missing  
or damaged, contact Black Box Technical Support at 724-746-5500  
or info@blackbox.com.

ACX048, ACX080, ACX160, ACX288, ACXC8, ACXC8F, ACXC16, ACXC16F, 
ACXC32, ACXC32F, ACXC48, ACXC48F, ACXC48F16, ACXC48F32, ACXC64, 
ACXC64F, ACXC80, ACXC80F:

• DKM FX or DKM FX Compact matrix

• (1) power cord per built-in power supply unit

• (1) serial control cable (DKM FXC includes a DB9 to RJ-45 adapter)

• Mounting accessories

• Quick Install Guide

• (1) CATx network cable (cross-wired)
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2.5 Device Views
In Sections 2.5.1 through 2.5.4, Figures 2-2 through 2-5 illustrate the ServSwitch 
DKM FX chassis models. Tables 2-4 through 2-7 describe their components.

NOTE: �The following images of the chassis are fully populated with I/O cards and 
are intended to be example diagrams. The chassis do not come with any 
I/O cards. You need to purchase the I/O cards separately.

2.5.1 ServSwitch DKM FX 48-Port (ACX048)

1	        2       3	           4            5      6  7

Figure 2-2. Front view, ACX048.

Table 2-4. ACX048 components.

Number Component

1 Slot for fan tray

2 Slot for Power Supply Unit 1

3 Slot for I/O Boards 1–6

4 Slot for Power Supply Unit 2

5 Slot for CPU board

6 Slot for air filter

7 Slot for Fan Tray 2
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2.5.2 ServSwitch DKM FX 80-Port (ACX080)

1                 2       3   		  4      5         6   7

Figure 2-3. Front view, ACX080.

Table 2-5. ACX080 components.

Number Component

1 Slot for fan tray

2 Slot for Power Supply Unit 1

3 Slot for I/O Boards 1–10

4 Slot for Power Supply Unit 2

5 Slot for CPU board

6 Slot for air filter

7 Slot for Fan Tray 2
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2.5.3 ServSwitch DKM FX 160-Port (ACX160)

1   2    	          3         4       5  6    8   7

Figure 2-4. Front view, ACX160.

Table 2-6. ACX160 components.

Number Component

1 Slot for Power Supply Unit 1

2 Slot for Fan Tray 1

3 Slot for Power Supply Unit 2

4 Slot for Fan Tray 2

5 Slot for I/O Boards 1–36

6 Slot for Power Supply Unit 3

7 Slot for CPU board

8 Grounding
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2.5.4 ServSwitch DKM FX 288-Port (ACX288)

1   2    	   3         4          5     6  7 8

Figure 2-5. Front view, ACX288.



Page 31724-746-5500   |   blackbox.com 

Chapter 2: Overview

Table 2-7. ACX288 components.

Number Component

1 Slot for Power Supply Unit 1

2 Slot for Fan Tray 1

3 Slot for Power Supply Unit 2

4 Slot for Fan Tray 2

5 Slot for I/O Boards 1–36

6 Slot for Power Supply Unit 3

7 Grounding

8 Slot for CPU board

NOTE: The ServSwitch DKM FX Compact models are described next.

2.5.5 ServSwitch DKM FX Compact 8-Port, CATx (ACXC8)

Figure 2-6. Front view, ACXC8.

Table 2-8. ACXC8 components. 

Number Component

1 I/O ports 1–8 (CATx)

2 Serial connection (RJ-45)

3 Network connection (RJ-45)

4 Connect to power supply

5 Connect to a 5-VDC power supply (redundancy, optional)
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2.5.6 ServSwitch DKM FX Compact 8-Port, SFP (ACXC8F)

Figure 2-7. Front view, ACXC8F.

Table 2-9. ACXC8F components. 

Number Component

1 I/O ports 1–8 (SFP)

2 Serial connection (RJ-45)

3 Network connection (RJ-45)

4 Connect to power supply

5 Connect to a 5-VDC power supply (redundancy, optional)
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2.5.7 ServSwitch DKM FX Compact 16-Port (ACXC16)

 1        					      2 3

Figure 2-8. Front view, ACXC16.

Table 2-10. ACXC16 components.

Number Component

1 I/O ports 1–16 (CATx)

2 Serial connection (RJ-45)

3 Network connection (RJ-45)

 1       2    3

Figure 2-9. Back view, ACXC16.

Table 2-11. ACXC16 back-panel components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.5.8 ServSwitch DKM FX Compact 16-Port Fiber (ACXC16F)

 1        					      2 3

Figure 2-10. Front view, ACXC16F.

Table 2-12. ACXC16F components.

Number Component

1 I/O ports 1–16 (SFP)

2 Serial connection (RJ-45)

3 Network connection (RJ-45)

 1       2    3

Figure 2-11. Back view, ACXC16F.

Table 2-13. ACXC16F back-panel components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.5.9 ServSwitch DKM FX Compact 32-Port (ACXC32)

 1        		   2    			    3 4

Figure 2-12. Front view, ACXC32.

Table 2-14. ACXC32 components.

Number Component

1 I/O ports 1–16 (CATx)

2 I/O ports 17–32 (CATx)

3 Serial connection (RJ-45)

4 Network connection (RJ-45)

 1        2    3

Figure 2-13. Back view, ACXC32.

Table 2-15. ACXC32 back-panel components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.5.10 ServSwitch DKM FX Compact 32-Port Fiber (ACXC32F)

 1        		   2    			     4

Figure 2-14. Front view, ACXC32F.

Table 2-16. ACXC32F components.

Number Component

1 I/O ports 1–16 (SFP)

2 I/O ports 17–32 (SFP)

3 Serial connection (RJ-45)

4 Network connection (RJ-45)

 1        2    3

Figure 2-15. Back view, ACXC32F.

Table 2-17. ACXC32F back-panel components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding

3
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2.5.11 ServSwitch DKM FX Compact 48-Port (ACXC48)

1		  2		  3	 4  5	

Figure 2-16. Front view, ACXC48.

Table 2-18. ACXC48 front-panel 
components.

Number Component

1 I/O ports 1–16 (CATx)

2 I/O ports 17–32 (CATx)

3 I/O ports 33–48 (CATx)

4 Serial connection (RJ-45)

5 Network connection (RJ-45)

 1        2    3

Figure 2-17. Back view, ACXC48.

Table 2-19. ACXC48 back-panel 
components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.5.12 ServSwitch DKM FX Compact 48-Port Fiber (ACXC48F)

1		  2		  3	 4  5	

Figure 2-18. Front view, ACXC48F.

Table 2-20. ACXC48F front-panel 
components.

Number Component

1 I/O ports 1–16 (SFP)

2 I/O ports 17–32 (SFP)

3 I/O ports 33–48 (SFP)

4 Serial connection (RJ-45)

5 Network connection (RJ-45)

 1        2    3

Figure 2-19. Back view, ACXC48F.

Table 2-21. ACXC48 back-panel 
components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.5.13 ServSwitch DKM FX Compact 64-Port

Figure 2-20. Front view, ACXC64.

Table 2-22. ACXC64 components.

Number Component

1 I/O ports 1–16 (CATx)

2 I/O ports 49–64 (CATx)

3 I/O ports 17–32 (CATx)

4 I/O ports 33–48 (CATx)

5 Serial connection (RJ-45)

6 Network connection (RJ-45)

Figure 2-21. Back view, ACXC64.

Table 2-23. ACXC64 back-panel components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.5.14 ServSwitch DKM FX Compact 64-Port Fiber (ACXC64F)

Figure 2-22. Front view, ACXC64F.

Table 2-24. ACXC64F components. 

Number Component

1 I/O ports 1–16 (SFP)

2 I/O ports 49–64 (SFP)

3 I/O ports 17–32 (SFP)

4 I/O ports 33–48 (SFP)

5 Serial connection (RJ-45)

6 Network connection (RJ-45)

Figure 2-23. Back view, ACXC64F.

Table 2-25. ACXC64F back-panel components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.5.15 ServSwitch DKM FX Compact 80-Port (ACXC80)

Figure 2-24. Front view, ACXC80.

Table 2-26. ACXC80 components. 

Number Component

1 I/O ports 1–16 (CATx)

2 I/O ports 49–64 (CATx)

3 I/O ports 17–32 (CATx)

4 I/O ports 65–80 (CATx)

5 I/O ports 33–48 (CATx)

6 Serial connection (RJ-45)

7 Network connection (RJ-45)

Figure 2-25. Back view, ACXC80.

Table 2-27. ACXC80 back-panel components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.5.16 ServSwitch DKM FX Compact 80-Port Fiber (ACXC80F)

Figure 2-26. Front view, ACXC80F.

Table 2-28. ACXC80F components. 

Number Component

1 I/O ports 1–16 (SFP)

2 I/O ports 49–64 (SFP)

3 I/O ports 17–32 (SFP)

4 I/O ports 65–80 (SFP)

5 I/O ports 33–48 (SFP)

6 Serial connection (RJ-45)

7 Network connection (RJ-45)

Figure 2-27. Back view, ACXC80.

Table 2-29. ACXC80 back-panel components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.5.17 ServSwitch DKM FX Compact 48 CATx Ports, 16 Fiber Ports 
(ACXC48F16)

Figure 2-28. Front view, ACXC48F16.

Table 2-30. ACXC48F16 components.

Number Component

1 I/O ports 1–16 (CATx)

2 I/O ports 49–64 (SFP)

3 I/O ports 17–32 (CATx)

4 I/O ports 33–48 (CATx)

5 Serial connection (RJ-45)

6 Network connection (RJ-45)

Figure 2-29. Back view, ACXC48F16.

Table 2-31. ACXC48F16 back-panel components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.5.18 ServSwitch DKM FX Compact 48 CATx Ports, 32 Fiber Ports 
(ACXC48F32) 

Figure 2-30. Front view, ACXC48F32.

Table 2-32. ACXC48F32 components. 

Number Component

1 I/O ports 1–16 (CATx)

2 I/O ports 49–64 (SFP)

3 I/O ports 17–32 (CATx)

4 I/O ports 65–80 (SFP)

5 I/O ports 33–48 (CATx)

6 Serial connection (RJ-45)

7 Network connection (RJ-45)

Figure 2-31. Back view, ACXC48F32.

Table 2-33. ACXC48F32 back-panel components.

Number Component

1 Power supply unit 1

2 Power supply unit 2

3 Grounding
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2.6 Diagnostics and Status

2.6.1 Status LEDs
The ServSwitch DKM FX and DKM FX Compact LED indicators are shown in 
Figures 2-12 through 2-22, and described in Tables 2-14 through 2-25.

1

2

Figure 2-32. CPU board, front view.
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Table 2-34. Status LEDs on the CPU board.

Number LED Status Description

1 Status 1

White CPU board is in registration process

Blue flashing Registration at the matrix is started

Red flashing Registration is in progess

Green flashing Operating condition

Green CPU board de-registered

2 Status 2

White CPU board is in registration process

Red flashing Registration at the matrix is started

Off Operating condition

NOTE: �Because of variations in the LED type, “white” may also appear as light  
purple or light blue.

1

2

1

2

ACXI08-C  ACXI08-SM    ACXI08-SDI  ACXI-8-HS  ACXI-8-SFP  ACXI08-6G

Figure 2-33. LEDs on the I/O boards. 
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Table 2-35. Status LEDs on the I/O boards.

Number LED Status Description

1 Status 1

Light blue I/O board in boot process

Red flashing I/O board in registration process

Red/Yellow flashing I/O board in service mode or firmware conflict with CPU board

Green flashing Operating condition, I/O board registered at the matrix

Green I/O board de-registered (locking pin pulled out)

2 Status 2

White I/O board in boot process

Blue I/O board in registration process

Blue flashing
Operating condition, communication active with CPU board 
active

Red flashing I/O board de-registered (locking pin pulled out)

CATx		    SFP fiber	     SFP coax

1

2
11
22

Figure 2-34. Ports status LEDs on the I/O boards.

Table 2-36. Port status LEDs on the I/O boards.

Number LED Status Description

1 Link status (green)

Off Port not activated

Flashing Port activated, no connection via interconnect cable

On Connection via interconnect cable OK, data traffic active

2 Link status (orange)

Off Port not activated

Flashing Port activated, no connection via interconnect cable

On Connection via interconnect cable OK, data traffic active
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1     2	   3

Figure 2-35. Status LEDs on the fan tray.

Table 2-37. Status LEDs on the fan tray.

Number LED Status Description

1 Status 1 (green) On Operating condition

2 Status 2 (blue)
Off Operating condition

On Error indication

3 Hot swap (blue)
Off Hot swap option deactivated

On Hot swap option activated
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   1  2 3

Figure 2-36. Status LEDs on the power supply unit (ACX288-PS).

Table 2-38. Status LEDs on the power supply unit  
(ACX288-PS).

Number LED Status Description

1 AC input OK (green) On Operating condition

2 DC output OK (green) On Operating condition

3 O/T (yellow)
Off Normal temperature

On High temperature

1

 

Figure 2-37. Status LEDs on the power supply unit (ACX080-PS).

Table 2-39. Status LEDs on the power supply unit  
(ACX080-PS).

Number LED Status Description

1
DC input OK (green) On Operating condition

DC output OK (green) Off No power supply
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Status LEDs on ACXC8, ACXC8F, ACXC16, ACXC16F, ACXC32, ACXC32F, 
ACXC48, ACXC48F16, ACXC38F32, ACXC64, ACXC64F, ACXC80, ACXC80F

      1 2

NOTE: �Because LED type varies, “white” might also appear as light purple or light 
blue.

LAN Port LEDs on the ACXC8, ACXC8F, ACXC16, ACXC16F, ACXC32, 
ACXC32F, ACXC48, ACXC48F16, ACXC38F32, ACXC64, ACXC64F, ACXC80, 
ACXC80F

 1  2

Number LED Status Description

1
Status LED 1 
(orange)

On Connection to network is available

Off No connection to network

2
Status LED 2 
(green)

Flashing Data traffic is active

Off Data traffic is not active
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I/O Port LEDs on the ACXC8, ACXC8F, ACXC16, ACXC16F, ACXC32, 
ACXC32F, ACXC48, ACXC48F16, ACXC38F32, ACXC64, ACXC64F, ACXC80, 
ACXC80F

 1 2

Number LED

1 Link status port 1

2 Link status port 2

Table 2-38. Status LEDs at the ports of the  
ACXI08-C, ACXI08-SM, ACXI08-SFP I/O boards.

Number LED Status Description

1 Link status

Off Initialization

Green Connection via interconnect cable is OK, data traffic is active

Orange Extender is not recognized

 1 2

Number LED Status Description

1
Status PSU 
1 (green)

On Operating condition

Off Power supply unit off

2
Status PSU 
2 (green)

On Operating condition

Off Power supply unit off
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Fan Tray Status LEDs on ACXC8, ACXC8F, ACXC16, ACXC16F, ACXC32, 
ACXC32F, ACXC48, ACXC48F16, ACXC38F32, ACXC64, ACXC64F, ACXC80, 
ACXC80F

 1 2

 1 2

Number LED Status Description

1
Left Fan Status 1 
(red)

On Error indication

Off Operating condition

2
Left Fan Status 2 
(green)

On Operating condition

Off Fan off

3
Right Fan Status 2 
(green)

On Operating condition

Off Fan off

4
Right Fan Status 1 
(red)

On Error indication

Off Operating condition
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2.6.2 Port Status
The connections and the switching status between the various consoles and CPUs 
are shown in this menu.

You can access the menu via Java.

Figure 2-39. OSD and Java icons.

Java® Tool

The current port configuration of the ServSwitch DKM FX is illustrated in this 
menu.

Select “Status > Matrix View” in the task area.

Figure 2-40. Menu Status—Matrix View screen, Example #1.
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Figure 2-41. Menu Status—Matrix View screen, Example #1.

Table 2-41. Connection status.

Color Description

Gray Port not connected

Yellow Video connection

Green KVM connection

Red Faulty Port/unconfigured USB 2.0 card
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The symbol in Table 2-42 indicates the extender that is recognized and defined at 
a certain port.

Table 2-42. Extender recognized.

Symbol Description

Port connected to a CPU unit

Port is connected to a CPU unit that is switched to a CON unit in Private Mode  
(see Section 3.7.3).

Port connected to a CON unit

Port connected to a CON unit with Shared Access to a CPU.

Port is connected to a CON unit that is connected to a CPU unit in Private Mode  
(see Section 3.7.3).

Port connected to a USB 2.0 CPU unit

Port connected t a USB 2.0 CON unit

Port is configured as a CON port for customer-specific applications.

Port is configured as a CPU port for customer-specific applications.

• Red framed ports are defined as “fixed” (for example, for USB 2.0 connections).

• The port with four static blue squares is currently selected.

• �If a port is selected, all the other ports will be shown transparently, except for 
those ports that are connected to the currently selected port. To clear a selected 
port, press the “Clear Selection” button.
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• �If there is a red cross on a port when switching by the matrix view, the console 
chosen to be connected does not have access rights to the respective CPU at 
this port.

NOTE: �To show the extender information of the currently selected port in the right 
part of the working area, press the left mouse button.

The information in Table 2-38 is available:

Table 2-43. Extender information.

Symbol Description

Extender name Name of the selected extenders

Extender type Type of the selected extender

Port ID Number of the selected port

Device name Name of the connected console or CPU

Connections Listing of assigned connections to the marked port (full access or video access)

NOTE: �To open the context menu for the currently selected port with further 
functions, press the right mouse button.

The context functions in Table 2-39 are available:

Table 2-44. Context functions.

Function Description

Open extender The menu for definition of the currently selected extender is opened

Open device The menu for definition of the currently selected console or CPU is opened

Switch The menu for execution of switching applications is opened

To reload the Matrix View:

• Press the “F5” key of a connected keyboard.

• Execute “Edit > Reload” in the menu bar.

• Press the “Reload ” button in the tool bar.

• Wait several seconds if ”automatic reload” checkbox is checked.
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2.6.3 Port Status Matrix Grid

In this menu, the connections and the switching status between the various CON 
and CPU Devices are shown within the Matrix Grid.

The port view is divided into the different Grid matrices. As a result, each matrix is 
displayed in an optimized view of 24 ports per line in order to be able to show 
also a larger number of ports.

You have the following option to access the menu:

Figure 2-42.

Java Tool

The current port configuration of the Matrix Grid is illustrated in this menu.

• Select Status > Grid Port View in the task area when connected to the matrix.

Figure 2-43. Menu Status—Grid Port View.

NOTE: �Functions, colors, and symbols used in the Grid Port View are identical to 
those in the port status of the Matrix View (see Section 2.6.2).
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2.6.4 Extender OSD

All extenders used with the matrix switch have an individual OSD to display the 
connection status of the console.

Figure 2-44. Example view of extender OSD.

Table 2-47. Extender OSD information.

Field Description

CON Name of the extender’s individual console

CPU Name of the currently connected CPU

Access

Full Access: The extender’s indivdual console has a KVM connection to the displayed CPU.

Video Access: The extender’s individual console has a video-only connection to the displayed CPU.

Private Mode: The extender’s individual console has a Private Mode connection to the displayed 
CPU.

Not connected: The individual console is not connected to a CPU.

SHARED
x device(s) shows the exact number of devices connected to the current CPU. If the field remains 
empty, no other shared connections are active.
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NOTE: �If the Mouse Connect or Keyboard Connect options are used, the name of 
the console with keyboard/mouse control will be displayed at those  
consoles that do not have K/M control at the moment. The console is  
displayed in a yellow color under “Access.”

2.6.5 Network Status

The current network configuration is shown in this menu.

You can access the menu via OSD or Java:

Figure 2-45. OSD and Java icons.

OSD

Select “Status > Network” in the main menu.

Figure 2-40. Status—Network screen.
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The following information is shown in the Network Status menu:

Table 2-48. Network status.

Field Description

DHCP Information if the network settings are applied dynamically. Display Y (Yes) or N (No)

IP address Information about the IP address as provided manually or via DHCP

Subnet mask Information about the subnet mask as provided manually or via DHCP

Gateway Information about the gateway address as provided manually or via DHCP

MAC ID Information about the MAC address in the matrix

Java Tool

1. Select “Status > Matrix View” in the task area.

Figure 2-46. Menu status—matrix view.

2. �Use the left-mouse button to click on the network port of the CPU board.  
The corresponding network status will be shown in the right part of the  
working area.
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2.6.6 Firmware Status Matrix
The current firmware status of the installed boards is shown in this menu.

You can access the menu via OSD or Java:

Figure 2-47. OSD and Java icons.

 

Figure 2-48. Menu status—firmware.

Table 2-49. Menu status—firmware.

Field Description

Name Description of the modules

Type Type number

Ports Number of ports

Version Complete description of the firmware version

Date Date of the firmware version

Status Module status
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Java Tool

1. Select Status > Matrix Firmware in the task area.

Figure 2-49. Menu Status—Matrix Firmware.

2. �To read the firmware status and store it locally (file extension .dtf), select 
“Switch > Save Firmware Status to File....”

3. �To read the overall status of the ServSwitch DKM FX and store it locally (file 
extension .zip), select “Switch > Save Status to File...”, or press the respective 
button in the symbol bar.

The various modules can expanded and retracted in the “Name” column by  
clicking the left-mouse button on the plus or minus symbols to get a better  
overview.

Click on the plus/minus symbol in the upper right corner of the working area  
to expand and retract all module information with one click of the left-mouse  
button.
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2.6.7 Firmware Status Extender
The current firmware status of the connected extenders is shown in this menu.

To access the menu, use the Java tool.

Figure 2-50. Java Tool icon.

The following information is shown in this menu:

Table 2-50. Menu status—firmware status extender.

Field Description

Name Description of the firmware

Type Description of the extender module

Ports Number of ports

Cur. Version Complete description of the current firmware version

Cur. Date Date of the current firmware version

Select “Status >EXT Firmware” in the task area.

Figure 2-51. Menu status—EXT firmware.
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2.7 Trace Function
All events—for example, activities and switching operations of the ServSwitch 
DKM FX or FXC—are logged and displayed in this menu.

This function is used for diagnostic purposes.

You can request various trace views in the menu:

Figure 2-52. OSD icon.

The following information is shown in this menu:

Table 2-51. Trace menu function.

Field Description

Date Datestamp

Time Timestamp

Message Detailed description of the event

Trace possibilities

• �Select “Status > Trace IO Board” in the main menu to check the events on your 
current I/O board.

• Select “Status > Trace Matrix” to check the ServSwitch DKM FX events.

2.8 Syslog Monitoring
This menu logs matrix activities, switching operations, and the surveillance of 
function-critical components (such as fans or power supply units).

Click on the Java icon to access the menu:

Figure 2-53. Java icon.

To start Syslog Monitoring, proceed as follows:

Select the Monitoring symbol in the symbol bar.
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Figure 2-54. Monitoring Menu—Syslog.

Logging system activities start when opening the Monitoring menu, and remain 
active until the appropriate tab is closed.

NOTE: �Syslog messages are transmitted via UDP. Therefore, Port 514 within the 
used network should not be blocked, e.g., by a firewall.

During logging, the activities are written continuously into logging files and stored 
locally. This process can be set with various options.

Options

Select Extras > Options in the menu bar and open the Syslog tab.

The following options are available:

Table 2-52. Syslog options.

Option Description

Log File Directory Default directory to store the log files.

Log File Name Default name of the log file to be saved.

Log File Extension Default extension for the log file.

Maximum Log File Size (KB) Allowed maximum size of a log file.

Maximum Number of Log Files Allowed maximum number of log files.
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NOTE: �When the maximum log file size is reached, a new log file will be created. 
When the maximum number of log files is reached, the oldest one will be 
overwritten with the new information.

Filter Function

To filter relevant messages out of a number of logged activities of the matrix 
switch, the Syslog Monitoring offers various filter options.

To set and activate a filter, follow these steps:

1. Set the desired filter option(s) by activating the respective checkbox(es).

2. Activate the filter settings by pressing the “Filter” button.

3. To deactivate an activated filter setting, press the “Clear” button.

The following filter options are available:

Table 2-53. Filter options.

Option Description

Date Messages of a defined range will be filtered.

Facility Messages of a defined facility will be filtered.

Severity Messages of a defined severity will be filtered.

Host Messages of a defined host will be filtered.

Message Messages with defined text parts will be filtered.

NOTE: Filter options are not valid within the locally stored log files.

Recording Function

All messages shown in the Syslog are equipped with various recording functions.

• �To store the messages shown in the Syslog (filtered or unfiltered), press the 
“Save trace” button. The messages will be stored in a .txt file.

• To remove the messages shown in the Syslog, press the “Clear trace” button.

• �To stop recording the messages, press the “Pause” button. To continue  
recording, press the button again.

2.9 SNMP
Use SNMP to monitor all vital hardware and safety-critical parts of the matrix and 
to query their status. This function complies with the RFC 1157 standard.

NOTE: �During SNMP monitoring, we strongly recommend that you use a  
dedicated network to ensure access security.



Page 67724-746-5500   |   blackbox.com 

Chapter 2: Overview

You can access the menu via OSD or Java:

Figure 2-55. OSD and Java icons.

OSD

To activate SNMP via OSD, follow these steps:

1. Select “Configuration > SNMP” in the main menu.

Figure 2-56. 

2. �Set the “Enable” option to “Y” (Yes) under SNMP Agent. Activating this option 
grants permission to run an active query of the SNMP agent.

To activate the SNMP agent, proceed as follows:

1. Select “Configuration > SNMP” in the main menu.

2. �Set the “Enable Traps” option to “Y” (Yes) within SNMP server. This function 
allows an active transmission of trap messages from the SNMP agent to the 
SNMP server.
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3. Set the IP address of the SNMP server within Server Address.

4. Activate the requested traps by enabling them to “Y” (Yes).

You can select between the following traps:

Table 2-54. Traps.

Trap Description

Status Notification about the matrix status.

Temperature Notification about the temperature within the matrix.

Insert Board Notification about the insertion of a new I/O board into a 
slot.

Remove Board Notification about the removal of an I/O board out of a slot.

Invalid Board Notification about a improperly-working I/O board.

Insert Extender Notification about a newly-connected extender to the matrix 
or notification of a newly-established link between extender 
and matrix.

Remove Extender Notification about an extender removed from the matrix,  
notification about a switched off extender, or notification 
about an interrupted link between extender and matrix.

Switch 
Command

Notification about a performed switching operation at the 
matrix.

Fan Tray #1 Notification about the status of fan tray #1.

Fan Tray #2 Notification about the status of fan tray #2.

Power Supply #1 Notification about the status of power supply #1.

Power Supply #2 Notification about the status of power supply #2.

Power Supply #3 Notification about the status of power supply #3.

NOTE: �To activate the SNMP agent function, or the SNMP server function, you 
must restart the matrix.
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Java Tool

To activate SNMP via Java tool, follow these steps:

1. Select “System > Network” in the task area.

Figure 2-57. Menu System–Network.

2. �Activate the option SNMP Agent under SNMP. Activating this option grants 
permission for an active query of the SNMP agent.

To configure an SNMP server, proceed as follows:

1. Select “Configuration > Network” in the task area.

2. �Activate the “Enable Traps” option within SNMP Server. This function allows an 
active transmission of trap messages from the SNMP agent to the SNMP server.

3. Set the IP address of the SNMP within SNMP Server.

4. Activate the requested traps.

NOTE: �To activate the SNMP agent, or the SNMP server, you must restart the 
matrix.
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2.10 System Check
The System Check offers a diagnostic function for checking your current matrix 
configuration. The purpose of this feature is to find suboptimal and faulty settings.

The System Check is exclusively used for a plausibility check and does not make 
any active changes in the configuration.

You have the following option to access the menu:

Figure 2-58.

The following configuration parts are checked:

• Matrix Firmware

• Extender Firmware

• Multi-Screen Control

• Ext Units

• CPU Devices

• CON Devices

• User

• System Configuration

The following notification levels can be shown:

Table 2-55. Notification levels.

Level Description

OK (green) System check completed without any abnormalities.

WARNING 
(yellow)

System check revealed (without being system critical)  
incomplete parts of the configuration, firmware differences,  
duplications, or not connected extenders.

Error (red) System check revealed errors in the configuration that can have 
both functional and system critical influences on the system.
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NOTE: �If the messages ”WARNING” and “ERROR” are created by the System 
Check function, the problem will be described and a basic guideline will be  
provided. 

To start System Check, proceed as follows:

• Select the symbol System Check in the symbol bar.

Figure 2-59. Menu – System Check.
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3. Installation

3.1 Package Contents
• DKM FX or DKM FX Compact matrix

• (1) power cord per built-in power supply unit

• (1) serial control cable (DKM FXC includes a DB9 to RJ-45 adapter)

• Mounting accessories

• Quick Install Guide

• (1) CATx network cable (cross-wired)

3.2 System Setup
NOTE: �If you are a first-time user, we recommend that you set up the system  

in the same room as a test setup. This will allow you to identify and solve 
any cabling problems, and experiment with your system more conveniently.

Setup of the ServSwitch DKM FX

1. Install the CPU and I/O boards.

2. �Connect the keyboard, mouse, and monitor to the CPU board of the 
ServSwitch DKM FX.

3. Connect the ServSwitch DKM FX to the power supply.

4. �Open OSD via hotkey and log in with administrator rights in the main menu 
under configuration (see Section 4.2.1).

	 default login:  
	 username: admin 
	 password: admin 
	 default hotkeys: L-shift, L-shift, O

5. Begin configuration.

NOTE: �After configuring the system, we recommend that you save the  
configuration by selecting Configuration > Save and restart the ServSwitch 
DKM FX by selecting Restart Matrix.

6. �Optional: Establish a network connection between the ServSwitch DKM FX and 
the Java tool to set an extended configuration (see Section 4.2.2). The default 
address of the DKM is 192.168.100.99.
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Setup of the ServSwitch DKM FX Compact

1. Connect a CON unit to an I/O port of the matrix.

2. �Connect the keyboard, mouse, and monitor to the CON unit of the ServSwitch 
DKM FXC.

3. Connect the ServSwitch DKM FXC to the power supply.

4. �Open OSD via hotkey and log in with administrator rights in the main menu 
under configuration (see Section 4.2.1).

	 default login:  
	 username: admin 
	 password: admin 
	 default hotkeys: L-shift, L-shift, O

5. Begin configuration.

NOTE: �After configuring the system, we recommend that you save the  
configuration by selecting Configuration > Save and restart the ServSwitch 
DKM FX by selecting Restart Matrix. The alternative is to save the  
configuration, then open the configuration, then upload the configuration 
to the DKM FX. After you login, select the first option in the configuration 
and check the box that says: “Activate configuration after upload,” then 
press “Finish.” The DKM will reboot and the new configuration will be 
active.

6. �Optional: Establish a network connection between the ServSwitch DKM FX and 
the Java tool to set an extended configuration (see Section 4.2.2).

Extender Setup

1. �Connect the CON units to the ServSwitch DKM FX by using the interconnect 
cables (CATx or fiber).

2. �Connect the CON units to the input devices to be used (for example, keyboard 
and mouse).

3. Connect the 5-VDC power supply units to the CON units.

4. Check the basic function of the CON unit by opening the OSD via hotkey.

	 Default: (default: L-Shift, L-Shift, O)

5. �Connect the source (computer, CPU) to the CPU unit of the extender by using 
the provided connection cables.

6. �Connect the CPU unit to the matrix by using the interconnect cables (CATx or 
fiber).

7. �If you have a video matrix and you are using the universal or coaxial I/O cards, 
connect the video source directly to the matrix by using the interconnect cables 
(coax, fiber).
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8. Connect the 5-VDC power supply units to the CPU units.

9. Start the system.

3.3 Example Applications
The ServSwitch DKM FX supports a flexible configuration of your system  
environment:

For example, part of the ServSwitch DKM FX can be configured as a single-head, 
dual-head, quad-head, or octo-head computer or workstation, or even as a video 
matrix. You can also configure KVM and USB 2.0.

In addition to the access via OSD by the keyboard connected to the CPU board or 
an extender CON unit, you have the following access options:

• via Java Tool

• via serial interface

A connection to common media controls is possible, too, if you have the ACX-API 
installed.

Sections 3.2.1 through 3.2.4 describe typical installations of the ServSwitch DKM FX.

3.3.1 KVM Matrix
In single-head mode, up to 288 ports can be used either as an input or as an  
output port, depending on components and equipment. At the same time, the 
DKM offers non blocking access for all users (user access is not limited by the 
activities of another user).

1      2      3		         4		             3      5	     6

Figure 3-1. KVM using ServSwitch DKM FX application.
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Table 3-1. Single-head KVM matrix components.

Number Description

1 Source (computers, CPU)

2 CPU unit/transmitter

3 Interconnect cable

4 ServSwitch DKM FX or FXC

5 CON unit/receiver

6 Keyboards/mice/monitors

If you have a single-head console, you can also access a dual-head or quad-head 
console. However, you can control the system only at Monitor 1.

Any signal source can be switched to any number of monitors that will show the 
video signal at the same time. Even (optional) audio can be switched.

3.3.2 Video Matrix
If you use the ServSwitch DKM FX as a video matrix, it can switch up to 144 input 
ports to up to 144 output ports, depending on components and equipment.

NOTE: �144 ports means total ports that can break down to 1 input and 143  
outputs or the other way around.

1	      2      	 3	       2                     4	

Figure 3-2. Video using ServSwitch DKM FX application.
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Table 3-2. Video matrix components.

Number Description

1 Video sources, for example, an SDI camera

2 Interconnect cable

3 ServSwitch DKM FX or FXC

4 Monitors/Displays

3.3.3 Parallel Operation (Stacking)
If you have special configurations, especially at installations with several monitors 
per workstation, or you need additional support for USB 2.0 transmission paths, 
you can increase the number of CPUs and consoles connected using a parallel 
operation (stacking) of several ServSwitch DKM FX devices.

One of the DKM FX or DKM FX Compact matrices has to be defined as the  
master matrix. All the others have to be configured as slave matrices and the IP 
address of the master matrix has to be entered in the Master IP Address field. 
They have to be connected to the master matrix via the network connector  
(RJ-45) of the CPU board. The option Enable LAN Echo has to be activated at the 
master matrix.

If a switching command is done in the OSD, the slave matrices will also switch 
automatically.

NOTE: Switching of stacked devices might be delayed by several seconds.

1      2     3  	   4	    	        5   6             3   7	      8

Figure 3-3. Parallel operation (stacking) application.
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Table 3-3. Parallel operation  
(stacking) components.

Number Description

1 Single-head source (computer)

2 CPU unit/transmitter

3 Interconnect cable

4 ServSwitch DKM FX (master matrix)

5 ServSwitch DKM FX (sub-master matrix)

6 Network connection master/slave(s)

7 CON unit/receiver

8 Keyboard/monitor/mouse

3.3.4 Matrix Grid
You can use a matrix grid for applications where the required number of ports is 
not sufficient or important connections need to be made to several matrices to 
provide redundancy.

A matrix grid consists of one master matrix and at least one slave matrix. In its 
maximum configuration, it can consist of up to 16 matrices.

To build a matrix grid, the grid matrices are interconnected by “Grid Lines.” In this 
case, the slave matrices can be connected directly to the master matrix or 
between themselves.

When arranging the grid lines, various grid setups can be used, for example:  
a ring setup, a hub and spoke setup, or a fully connected setup of matrices.

Grid lines can process signals bidirectional (Smart Connect). Per grid line, one 
KVM connection can be transmitted. If multiple receivers are sharing one  
transmitter, you can support this over one cable/tie line between the matrixes, 
assuming all CONs/receivers are on one matrix and the transmitter/CPU is on a 
different matrix.

Switching operations that extend beyond a single grid matrix are made by the grid 
master. Local switching operations will still be made by each sub matrix.

To configure the matrix grid, see Section 4.13.
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Figure 3-4. Matrix Grid.
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3.3.5 Cascading
For applications that exceed the number of available ports, you can extend the 
system by cascading.

In this case, the ServSwitch DKM FX devices are connected by “tie lines.” The tie 
lines are dynamically configured to support connections in both directions.

To access cascaded matrices from a console, one of the matrices must be config-
ured as a sub-matrix.

1        2      3   	               4	     3	               5	     3      6         7

Figure 3-5. Cascading application.

Table 3-4. Cascading components.

Number Description

1 Source (computer, CPU)

2 CPU units/transmitters

3 Interconnect cable

4 ServSwitch DKM FX (sub matrix)

5 ServSwitch DKM FX (master matrix)

6 CON unit/receiver

7 Console (keyboard, monitor, mouse)
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4. Configuration

4.1 Command Mode
The ServSwitch DKM FX has a Command Mode that enables several functions via 
keyboard command during normal use.

To enter Command Mode, use a hotkey sequence, and to exit Command Mode, 
press <Esc>. While in Command Mode, the Shift and Scroll LEDs on the console 
keyboard will flash.

NOTE: �In Command Mode, normal keyboard and mouse operation will cease.  
Only selected keyboard commands are available.

NOTE: �If there is no keyboard command executed within 10 seconds after  
activating Command Mode, it willl be automatically deactivated.

The following table lists the keyboard commands to enter/exit Command Mode 
and to change the hotkey sequence:

Table 4-1. Command mode components.

Function Keyboard command

Enter Command Mode (default) 2x <Left-Shift> (or hotkey)

Exit Command Mode <Esc>

Change hotkey sequence

<hotkey>, <c>, <new hotkey code>, <Enter>

Earlier versions of firmware (before 9/30/2011): 
<Left Ctrl> + Left Shift> + <c>, <hotkey Code>, <Enter>

NOTE: �<Key> + <Key> = Press keys simultaneously; <Key>, <Key> = Press keys 
successively, 2x <Key> = Press key quickly, twice in a row (similar to a 
mouse double-click).
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You can change the hotkey sequence to enter Command Mode. The following 
table lists the hotkey codes for the available key sequences:

Table 4-2. Command mode components.

Hotkey code Hotkey

0 Freely selectable (for firmware 12/1/2012 or later)

2 2x <Scroll>

3 2x <Left-Shift>

4 2x <Left-Ctrl>

5 2x <Left-Alt>

6 2x <Right-Shift>

7 2x <Right-Ctrl>

8 2x <Right-Alt>

NOTE: �When using the DKM FX or DKM FXC with another KVM switch, be sure 
the hotkeys do not match on both switches; otherwise, the KVM closest to 
the physical keyboard and mouse at the user station will execute the  
hotkeys and not pass them on to the DKM FX or DKM FXC.

Set freely selectable “Hotkey” (exemplary)

To set a freely selectable Hotkey (for example, <O> <space>), use the following  
keyboard sequence:

<current “Hotkey”>, <c>, <0>, <Space>, <Enter>

Set “Hotkey” for direct OSD access

When setting a second hotkey, next to the hotkey for standard functions, this  
hotkey can be exclusively used for opening the OSD directly.

To select a hotkey from the hotkey table for opening OSD directly, use the  
following keyboard sequence:

<current hotkey>, <f>, <hotkey code>, <Enter>

To select a freely selectable hotkey (e.g., 2x <Space>) for opening OSD directly, 
use the following keyboard sequence:

<current hotkey>, <f>, <0>, <Space>, <Enter>
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Reset “Hotkey” 

To set a Hotkey back to the default settings of the extender, press the key  
combination <Right-Shift> + <Del> within 5 seconds after switching on the CON 
unit or plugging in a keyboard.

4.2 Control Options
The ServSwitch DKM FX or FXC contains an internal CPU that enables you to  
control all functions from any console without the need for an external CPU or 
media control.

You can access the ServSwitch DKM FX for configuration and operation in three 
ways:

• via OSD —configuration and operation

• via Java Tool—configuration and operation

• via serial interface—operation only

4.2.1 Control via OSD

Figure 4-1. OSD icon.

Via OSD (on-screen display), you can set the configuration of the ServSwitch DKM 
FX operating system. The settings of the Configuration menu are described in this 
chapter. All other menus are described in later chapters.

You can enter the OSD of the ServSwitch DKM FX:

• via keyboard connected to the CPU board

NOTE: You cannot view/control the computers from the CPU board.

• via keyboard connected to a CON unit of an extender

Entering OSD

1. Start Command Mode with the hotkey (see Section 4.1).

2. Press <o> to open OSD. You will see a list of all available CPUs as a start menu.

3. Press <Esc> to enter the main menu.
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NOTE: �If the “Enable CPU Selection” option is activated in the Configuration 
menu, the list of computers that can be selected will be opened. To skip 
this list, press <F7>.

Leaving OSD

• �Press the <Esc> key in the main menu, or simultaneously press <Left-Shift> + 
<Esc> anywhere within the OSD. The OSD will close without any further  
changes and the currently active CPU connection will display.

Menu Structure

Figure 4-2. Menu structure.

The general layout of the OSD is structured into three areas:

• Upper status area (top-most two text lines)

• Working area

• Lower status area (lowest two text lines)
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Keyboard control

You can select between the following keyboard commands:

Table 4-3. Keyboard commands.

Function
Keyboard 
command

Left cursor—only within an input field or a switching screen <Cursor-Left>

Right cursor—only within an input field or a switching screen <Cursor-Right>

• In input fields: Line up (with wrap-around)

• In menus: Line up (without wrap-around)
<Cursor-Up>

• In input fields: Line down (with wrap-around)

• In menus: Line down (without wrap-around)
<Cursor-Down>

Previous page in menus with more than one page <Page-Up>

Next page in menus with more than one page <Page-Down>

Next input field <Tab>

Previous input field <Left-Shift> + <Tab>

Next option in selection fields <+>

Previous option in selection fields <->

Switching in selection fields between two conditions,  
for example, between ON/OFF or Y(Yes)/N(No)

<Space>

• In menus with input fields: Save data

• In menus: Select menu item
<Enter>

• In menus with input fields: Cancel data input without saving.

• In menus with selection fields: Go back to the superior menu
<Esc>
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Sorting Function

You can sort lists and tables in the Java Tool for fast and smooth searching.

Table 4-4. Sorting functions.

Function
Keyboard 
command

Sort ID numbers in a descending order or in an ascending order by  
pressing the keyboard command twice (ID)

<F1>

Sort ID names in a descending order or in an ascending order by pressing 
the keyboard command twice (Name)

<F2>

Go to the next result in the list of results for the search field (Next) <F3>

Go to the previous result in the list of results for the search field (Previous) <F3>

Refresh the currently shown list (Previous) <F4>

Refresh the currently shown field (Refresh) <F5>

Jump between the search field and the list of results (Find) <F6>

Password request

You have to log in with administrator rights to be able to set configurations.

Figure 4-3. Login Menu screen.
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Access to the configuration menu requires administrator rights. Login is  
mandatory.

Table 4-5. Menu login parameters.

Field Input

User admin

Password admin

Press the <F10> key in the main menu of the OSD to open the login mask. To log 
out a user, press the <F10> key again.

NOTE: �For security reasons, change the administrator password as soon as  
possible.

NOTE: �If needed, create a secondary administrator user and password in case the 
administrator of the system is not available and you need access. If you lose 
the password for the admin account, there is no way to retrieve it. We  
recommend that you set up a second admin account and keep the  
credentials in a safe place.

4.2.2 Control via Java Tool

Figure 4-4. Java icon.

Requirements

If you want to use the Java tool, you need these items:

• �Computer with an executable Java tool and an installed Java Runtime 
Environment (JRE, version 1.6 or higher). You can download the latest version 
from the Java website.

• Java Tool software. This tool is available at the Black Box website or FTP site.

• �Available network connection between the Java tool and the ServSwitch DKM 
FX or FXC

NOTE: �Contact your system administrator concerning JRE and network  
connection.

Installation of the Java Tool

The Java tool is available as a single executable program file that does not require 
a separate installation.
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Copy the tool after receiving the file to a directory on your computer. All of the 
config files that the Java tool uses will be stored within the same directory as the 
Java executable program.

If you do not have the Java Tool, you can download it from the blackbox.com 
website.  Simply go to the website and search for ACX048. On the product page, 
scroll down until you see the "Resources" tab and click on it. You can now  
download the latest Java Tool available.

NOTE: �If you do not have a Java tool, contact Black Box Technical Support  
at 724-746-5500 or info@blackbox.com. 

Computer Connection to the ServSwitch DKM FX

NOTE: �For a direct connection between the computer and ServSwitch DKM FX, 
use a cross-wired network cable.

          �For a connection between the computer and ServSwitch DKM FX via 
switch or hub, use a straight-pinned network cable.

Do not use a network connection between Java Tool and matrix that is  
primarily used for transmitting audio data.

Connect the network cable to the RJ-45 port of the computer and CPU board of 
the ServSwitch DKM FX.

Start of the Java Tool

Open the Java tool by a double-clicking on the program icon or use the <Enter> 
key on the keyboard.

Connection to the Matrix

NOTE: �When connecting to the matrix using the Java Tool, make sure the user 
that you are logging in as has FTP rights.

1. Open the Java tool.

2. Select Matrix > Connect in the menu bar.

3. �Enter the IP address in the popup input field according to the network  
configuration of the ServSwitch DKM FX. (Default IP: 192.168.100.99)

4. �Enter the user name and password for the ServSwitch DKM FX.  
(Default: “admin” admin.)

5. Confirm ywith the “OK” button or reject with “Cancel.”
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Figure 4-5. Menu Connection screen.

NOTE: �Up to 12 connections between the matrix and the Java tool can be  
established at the same time because available sockets are limited. When 
you are done using the Java Tool, be sure to correctly disconnect/logout 
from the switch. If you close the Java Tool before disconnecting from the 
switch, the socket being used will not be released for a certain period of 
time. Once you use all 12 sockets, you will get an error message when 
attempting to connect to the DKM FX or DKM FXC.
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Menu structure

Figure 4-6. Example menu view (system-switch).  

The menu structure of the Java tools is subdivided into various sections:

• Menu bar (top line)

• Toolbar (second line)

• Tab bar (third line)

• Task area (left menu section)

• Working area (right menu section)

• Status bar (bottom line section)

Operating Instructions

The operation of the Java tool is intuitive and corresponds to the user interface of 
common operating systems.

The Java tool contains its own support function.

You can activate or deactivate the integrated help texts in the working area of the 
Java tool by checking the box in the upper right corner.
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Mouse Control

You can select between the following mouse commands:

Table 4-6. Mouse commands.

Function Mouse command

Menu selection, marking Left mouse button

Open function-specific selection menus Double-click the left mouse button

Open content-specific selection menus Right mouse button

Keyboard Control

You can select between the following keyboard commands:

Table 4-7. Keyboard commands.

Function Keyboard command

Cursor to the left <Cursor Left>

Cursor to the right <Cursor Right>

Line up <Cursor Up>

Line down <Cursor Down>

Previous page in input or status menus with more than one page <Page Up>

Next page in input or status menus with more than one page <Page Down>

Next field in input menus <Tab>

Previous field in input menus <Left-Shift> + <Tab>

• �Switching in selection fields between two conditions (checkmark or not)

• �Open already marked fields with editing or selecting capablility
<Space>

• �In menus: data saving

• Menu item selection
<Enter>

• �Leave tables

• Jump from tables into the next field
<Ctrl> + <Tab>
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Table 4-7 (Continued). Keyboard commands.

Function Keyboard command

• Leave tables

• Jump from tables into the previous field

<Ctrl> + <Left-Shift> + 
<Tab>

NOTE: �Various functions within the menus in the menu bar can be executed with 
the provided keyboard commands that are listed to the right of the  
respective menu item (for example, press <Ctrl> + <S> to execute “Save”).

Reload Options

The information shown in the Java tool can be reloaded in different ways.

• Via <F5> key on the used keyboard

• Via Edit > Reload in the menu bar

• Via “Reload” Symbol in the symbol bar

Context Function

The Java tool offers several context functions that support a user-friendly and 
effective operation of the tool. The context functions are described in the  
respective chapters.

To execute a context function, use the right mouse button on the corresponding 
field and select the desired function.

Sorting Function

Lists and tables in the Java tool offer a sorting function for fast and smooth 
searching.

1. �For ascending sort status, use the left mouse button once to click into the 
header of the column you want to sort.

    The sort status is indicated by an arrow that points upwards.

2. �For descending sort, use the left mouse button twice to click on the header of 
the column that you want to sort. The sort is displayed by an arrow that points 
downwards.

3. �To cancel the sort, use the left mouse button once or twice to click on the 
header of the column that is sorted until the displayed arrow disappears.
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Filter Function

Lists and tables in the Java tool offer a filter function that enables fast and smooth 
searching.

1. �To activate a filter, use the right-mouse button to click on the header of the  
column you want to filter and select Set Filter.

2. Write the word or part of a word you want to filter directly into the header.

    The filter results are shown immediately.

3. �To delete a filter, use the right mouse button to click on the header of the  
column you want to filter and select “Clear Filter.”

NOTE: 	� An asterisk in the header indicates an active filter. 

       	� The filter function is based on the functional principle of common Web 
search engines.

Configuration in the Java Tool (Off-line Configuration)

You can only change configuration and system settings via the Java tool in off-line 
mode without a direct connection between ServSwitch DKM FX and Java tool.

To activate a configuration in the ServSwitch DKM FX:

1. Select “File > Upload to” in the menu bar.

2. �Enter the IP address of the ServSwitch DKM FX and the name and password of 
the authorized user. Then, select the storage location of the new configuration 
(default or config 01–08) in the menu “Select Configuration.”

3. �Select “Matrix > Connect” in the menu bar and enter the IP address of the 
matrix and the name and password for the authorized user.

4. �Select “Administration > Activate Configuration” in the task area and select the 
storage location that you selected above.

5. Use the “Activate” button to open the selected configuration within the matrix.

NOTE: �If you want to use the current configuration, check the box at the bottom 
of the dialog window before proceeding.

The connection and the open tab will close, and the matrix will restart.

NOTE: �During the activation of a configuration, the matrix is temporarily not  
available because it is rebooting.
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On-line Configuration

Configurations and system settings can be also modified using the Java tool in 
On-line mode with an active connection between matrix and Java tool.

Figure 4-7. Menu System—System Data.

To edit a configuration in online mode, proceed as follows:

1. �Select the menu item “Matrix > Activate Online Configuration Mode.” This  
setting will also be shown in the lower part of the working area. You can also 
activate the “online configuration mode” by clicking on the gear icon in the 
shortcut tool bar.

2. �Make any changes in the configuration and system settings and confirm by  
pressing the “Apply” button. The changes will be applied immediately.

3. �To deactivate the On-line mode, select the menu item “Matrix > Deactivate 
Online Configuration Mode” in the menu bar.

Options menu

You can adapt and customize the Java tool by editing various default settings.

To activate or change the default settings, proceed as follows:

Select “Extras > Options” in the menu bar. The tab Default Settings will open.
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The default settings parameters are:

Table 4-8. Default settings.

Option Description

IP/Hostname Default IP address of the matrix required for connection.

User Default user name used for connection.

Configuration Directory Default directory for configuration files.

Firmware Directory Default directory for update files.

Status Directory Default directory for the firmware status.

Import/Export Directory Default directory for import and export files.

Presets Directory Default directory for macro files.

To set various font sizes for the Java tool, proceed as follows:

1. Select “Extras > Options” in the menu bar.

2. Open the Font tab.

3. Select the desired font size (normal or large).

Report

The Java tool is equipped with a report function that shows the current switching 
status and all relevant parts of the matrix configuration in a PDF file.

To create a report, proceed as follows:

1. Select “File > Report...” in the menu bar. A selection assistant will be opened.

2. �Select those contents that should be included in the report (Matrix View,  
EXT Units, CPU Devices, CON Devices, and Users) and confirm with the  
“Next >” button.

3. �Select the preferred location for storage of the report and confirm with the 
“Finish” button.

The report will be created as a PDF file.
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Figure 4-8. Menu File > Report.

NOTE: �The report function can be used in both On-line or Off-line mode of the 
Java tool.

4.2.3 Control via Serial Interface

Figure 4-9. RS-232 icon.

The ServSwitch DKM FX operating system offers various functions for external 
RS-232 (serial) communication. There are telegrams for switching single or all  
connections available, both unidirectional and bidirectional. There are also  
telegrams for an overall definition of the total switching status and for saving  
and loading such switching states.

The ServSwitch DKM FX has an option that provides an echo of all affected 
switching operations via serial interface or network interface. This will allow the 
system to communicate with other applications and provide switch status. 

You can also switch sub-master DKM FX or FXC clones as slaves (stacking) via a 
serial network interface.
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4.3 Assignment
The ServSwitch DKM FX enables you to create a console-specific or a CPU-specific 
assignment.

• You can assign virtual CPUs to real CPUs.

• You can assign real consoles to virtual consoles.

4.3.1 Virtual CPU
You can assign virtual to real CPUs in this menu. Switch several consoles to the 
same CPU. If there are several consoles connected to a virtual CPU that is assigned 
to a real CPU, you will only have to change the real CPU once and all the consoles 
will receive the video signal of the new CPU.

You can access the menu via OSD or Java.

Figure 4-10. OSD and Java icons.

OSD

Select “Assignments > Virtual CPU Devices” in the main menu.

 

Figure 4-11. Menu Assignments – Virtual CPU Devices.
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For an assignment, proceed as follows:

1. �Select the virtual CPU in the list Virtual Devices that has to be assigned to a real 
CPU.

2. Press the “Edit” button.

3. �Select the CPU in the list Real Devices that has to be assigned to the selected 
virtual CPU.

4. Press the “OK” button to confirm the assignment.

The assignment will be done.

NOTE: Only one virtual CPU can be assigned to a real CPU.

Java Tool

Select “Assignment > Virtual CPU Devices” in the task area.

Figure 4-12. Menu assignment—Virtual CPU devices screen.
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For an assignment, proceed as follows:

1. Select a virtual CPU in the “Virtual CPU” list.

2. Double-click in the “Real CPU” column to get a list of all available real CPUs.

3. Select a real CPU.

You can select between the following buttons:

Table 4-9. Selection buttons.

Button Function

Send Send assignments to the matrix

Reload Reload changes

NOTE: �By activating the “Auto Send” function in the left lower corner of the  
working area, switching operations will occur immediately without  
pressing the “Send” button to confirm.

The selection boxes in the Real CPU column contain a filter function for an easy 
selection of single consoles from a larger pool of consoles.

The Java tool also offers the possibility to go directly from the Assignment  menu 
to the Definition menu to check specific settings for the respective console or 
CPU.

Use the right-mouse button to select the respective console or CPU and select 
“Open CON Device” or “Open CPU Device.”

4.3.2 Virtual Console
You can assign real consoles to virtual consoles in this menu.

Using this function, you can change access permissions of the virtual console and 
apply them to all assigned real consoles, too.

Virtual consoles can be switched exactly in the same way as real consoles. If a  
virtual console is switched to a CPU, all real consoles that are assigned to the  
virtual console will receive the video signal. The real console that is last scheduled 
in the list of assignments will additionally receive keyboard and mouse control.
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You can access the menu via OSD or Java.

Figure 4-13. OSD and Java icons.

OSD

Select “Assignments > Virtual CON Devices” in the main menu.

Figure 4-14. Menu Assignments – Virtual CON Devices.

For an assignment, proceed as follows:

1. �From the “Real Devices” list, select the real console that has to be assigned to a 
virtual CPU.

2. Press the “Edit” button.

3. �Select the virtual console in the Virtual Devices list that has to be assigned to 
the selected real console.

4. Press the “OK” button to confirm the assignment.

NOTE: A virtual console can be assigned to more than one real console.
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Java Tool

Select “Assignment > Real to Virtual Console” in the task area.

Figure 4-15. Menu Assignment—Virtual Console Devices screen.

To place an assignment, proceed as follows:

1. Select the required real console in the “Real Console” table.

2. �Double-click in the “Virtual Console” column to get a list of all available virtual 
consoles.

3. Select the required virtual console.

You can select between the following buttons:

Table 4-10. Send and Cancel  
selection buttons.

Button Function

Send Send assignments to the matrix

Cancel Reject changes

NOTE: �If you activate the Auto Send function in the left lower corner of the  
working area, switching operations will occur automatically without  
pressing the Send button to confirm. 
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The selection boxes in the Virtual Console column contain a filter function so you 
can easily select a single CPU from a larger pool of CPUs (see Section 4.2.2).

4.4 System Settings
You can configure the following system settings on the ServSwitch DKM FX.

NOTE: Only users with administrator rights can configure the system settings.

4.4.1 System Data
The system configuration is set in this menu.

You can access the menu via OSD and Java:

Figure 4-16. OSD and Java icons.

Select from the following settings:

Table 4-11. System data settings.

Field Selection Description

Device Text Enter the device name of the matrix (default: SWITCH 01)

Name Text
Enter the name of the configuration that is used to save the current 
settings (default: Standard)

Info Text
Additional text field to describe the configuration (default: Factory  
settings)

Sub matrix

Activated

If the matrix is defined as a slave in the OSD, the user will lose control 
automatically. Use the keyboard command <Shift><Shift><s><o>to 
recover control. The OSD will open again in the matrix defined as 
slave.

Deactivated Function not active (default)

Load Default

activated
Starting the matrix after a restart or a switch-on with the default  
configuration.

deactivated
Starting the matrix after a restart or a switch-on with the last-saved  
configuration (default).

Auto Save
Activated

Save the current configuration of the matrix in the flash memory 
periodically.

Deactivated Function not active (default)
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Table 4-11 (continued). System data settings.

Field Selection Description

Enable COM 
echo

Activated

Send all performed switching commands in the matrix as an echo via 
serial interface.

NOTE: �Enable this function when using media control via the serial 
interface.

Deactivated Function not active (default)

Enable LAN 
echo

Activated

Send all performed switching commands in the matrix as an echo via 
LAN connection.

NOTE: �Enable this function when using media control via the serial 
interface.

Deactivated Function not active (default)

Slave matrix
Activated

Synchronize the slave matrix according to the switch status of the  
master matrix.

Deactivated Function not active (default)

Master IP 
address

Numerical value
Set the network address of the master matrix (default value: 
000.000.000.000)

Hor. Mouse 
Speed 1/x

1–9 Adjust the horizontal mouse speed, 1= slow, 9 = fast (default value: 5)

Ver. Mouse 
Speed 1/x

1–9 Adjust the vertical mouse speed, 1= slow, 9 = fast (default value: 5)

Double click 
time

100–800 ms Adjusts the time slot for a double click (default value: 200 ms)

Keyboard 
layout

Region
Set the OSD keyboard layout according to the used keyboard;  
Default: English (US)
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OSD

Select Configuration > System in the main menu.

Figure 4-17. Menu Configuration—System screen.

Table 4-12. Cancel and Okay 
selection buttons.

Button Function

Cancel Reject changes

Okay Save changes
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Java Tool

Figure 4-18. Menu System—System Data.

4.4.2 Automatic ID
From this menu, you can automatically create CPU and CON devices‘ settings by 
connecting a new extender unit.

You can access the menu via OSD or Java:

Figure 4-19. OSD and Java icons.
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You can select between the following settings:

Table 4-13. Automatic ID settings.

Field Selection Description

Enable Auto 
Config

Activated
Automatically creates a new CPU or CON device if new extender units 
are connected (default)

Deactivated Function not active

ID Real CPU 
Device

Numerical value Initial value of the automatic ID for real CPUs (default value: 1000)

ID Virtual 
CPU Device

Numerical value Initial value of the automatic ID for virtual CPUs (default value: 2000)

ID Real CON 
Device

Numerical value Initial value of the automatic ID for real CONs (default value: 3000)

ID Virtual 
CON Device

Numerical value Initial value of the automatic ID for virtual CONs (default value: 4000)

OSD

Select Configuration > System in the main menu.

 

Figure 4-20. Menu Configuration—System screen.
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Table 4-14. Cancel and Okay 
selection buttons.

Button Function

Cancel Reject changes

Okay Save changes

Java Tool

Select “System > Automatic ID” in the task area.

Figure 4-21. Menu System—Automatic ID screen.

4.4.3 Access
The access configuration is set in this menu.

You have the following options to access the menu:

Figure 4-22. OSD and Java icons.
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Table 4-15. Access settings.

Field Selection Description

Force User 
Login

Activated
The user has to log in with a user name and a password code to enter 
OSD. Thereafter, the user remains logged in until he explicitly logs out 
or an auto logout is initiated.

Deactivated Function not active (default)

Enable User 
ACL

Activated

CPU access is restricted according to the permissions in the ACL 
(Access Control List). 

• User login is required.

• Switching by keyboard hotkeys requires a prior login.

Deactivated Function not active (default)

Enable 
Console ACL

activated
CPU access is restricted according to the permissions of the respective 
Access Control List (ACL). No login is required.

deactivated Function not active (default)

Enable new 
user

activated Newly-created users automatically receive access to all CPUs

deactivated Function not active (default)

Enable new 
CON

activated Newly-created CON devices automatically receive access to all CPUs

deactivated Function not active (default)

Auto 
Disconnect

activated
Upon opening the OSD, the console will automatically disconnect from 
the current CPU.

deactivated Function not active (default)

OSD 
Timeout

0–999 seconds
Period of inactivity after which OSD will close automatically.

• Select 0 seconds, for no timeout (default: 0 seconds)

Auto Logout 0–999 seconds

Period of inactivity of a logged-in user after which he will be  
automatically logged out at the console.

There might be a disconnect because of the logout, depending on the 
defined rights in each CON and user ACL.

• Select 0 minutes, for an automatic logout when leaving OSD.

• �Using the setting -1 allows the user to be logged in permanently, 
until a manual logout is executed.

• �The timer is not active as long as the OSD is open.  
(default: 0 minutes)
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OSD

Select “Configuration > Access” in the main menu.

Figure 4-23. Menu Configuration Access screen.

You can select between the following buttons:

Table 4-16. Cancel and Save 
selection buttons.

Button Function

Cancel Reject changes

Save Save changes
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Java Tool

Select “System > Access” in the task area.

Figure 4-24. Menu System—Access screen.

4.4.4 Switch
The configuration of the switching parameters is set in this menu.

You have the following possibilities to access the menu:

Figure 4-25. OSD and Java icons.
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You can select between the following settings:

Table 4-17. Switch settings.

Field Selection Description

Video 
Sharing

Activated

The user can switch to any CPU as an observer, even to ones that are 
already assigned to another user (observer without keyboard/mouse 
access).

• NOTE: Switch with the <Space> key , not the <Enter> key.

• �The operator will not be informed if further users connect as an 
observer to the CPU that is connected to his console.

Deactivated Function not active (default)

Force 
Connect

Activated

The user can connect to every single CPU as an operator, even to ones 
that are related to another user.

• NOTE: The previous user is set to video-only status.

• To share K/M control, Force Connect must be activated.

Deactivated Function not active (default)

Force 
Disconnect

Activated

Extension of Force Connect: If the user connects to a CPU as an  
operator that is already related to another user, the connection to the 
previous user will be completely disconnected.

NOTE: To share K/M control, Force Connect must be deactivated.

Deactivated Function not active (default)

CPU Auto 
Connect

Activated
If a console is not connected to a CPU, you can establish an automatic 
connection to the next available CPU by pressing any key or mouse 
button.

Deactivated Function not active (default)

CPU 
Timeout

0–999  
minutes

Period of inactivity after which a console will automatically disconnect 
from its current CPU. (default value = 0 minutes)

Keyboard 
Connect

Activated Activate request of K/M control by keyboard event (key will be lost)

Deactivated Function not active (default)

Mouse 
Connect

Activated Activate request of K/M control by mouse event

Deactivated Function not active (default)
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Table 4-17 (continued). Switch settings.

Field Selection Description

Release Time
0–999  
seconds

Period of inactivity of a connected console after which K/M control 
can be requested by other consoles connected to the CPU.

• NOTE: Set “0” for an immediate transfer in real time.

• �Only one console can have keyboard and mouse control at the same 
time. The other consoles that are connected to the same CPU have a 
video-only status (default value: 10 seconds)

NOTE: �If the “Keyboard Connect” and/or “Mouse Connect” options are activated, 
the Release Time condition must be met until a new user gains control.

OSD

Select “Configuration > Switch” in the main menu.

Figure 4-26. Menu configuration–System.
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Table 4-18. Cancel and Save 
selection buttons.

Button Function

Cancel Reject changes

Save Save changes

Java Tool

Select “System > Switch” in the task area.

Figure 4-27. Menu system—switch.

4.4.5 Network
The network configuration is set in this menu.

You have the following possibilities to access the menu:

Figure 4-28. OSD and Java icons.
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Table 4-19. Network settings.

Field Selection Description

DHCP
Activated

The network settings are automatically supplied by a DHCP server 
(default)

Deactivated Function not active

IP address Byte Input of the IP address in the form “192.168.1.1,” if DHCP is not active

Subnet mask Byte
Input of the subnet mask in the form “255.255.255.0,” if DHCP is not 
active (default 255.255.255.0)

Gateway Byte
Input of the subnet mask in the form “192.168.1.1,” if DHCP is not 
active

API service
Activated

LAN interface at the DKM FX or FXC is activated for access via Java tool 
(API service port 5555)

Deactivated Function not active

FTP server
Activated FTP server for tranmission of configuration files activated.

Deactivated Function not active

Syslog
Activated Syslog server for status request is active

Deactivated Function not active

Syslog server Byte Input of the IP address of the Syslog server in the form “192.168.1.1”

Trace

DEB

Activate debug messages in Trace (default: Yes); 
NOTE: The debug messages are exclusively for matrix diagnostics. They 
only should be activated after consultation with Black Box. Otherwise, 
increased traffic of data might limit the performance of the CPU board.

INF Activate information messages in Trace (default: Yes)

NOT Activate notification messages in Trace (default: Yes)

WAR Activate warning messages in Trace (default: Yes)

ERR Activate error messages in Trace (default: Yes)

Syslog

DEB

Activate debug messages in Syslog (default: Yes); 
NOTE: The debug messages are exclusively for matrix diagnostics. They 
only should be activated after consultation with Black Box. Otherwise, 
increased traffic of data might limit the performance of the CPU board.

INF Activate information messages in Syslog (default: Yes)

NOT Activate notification messages in Syslog (default: Yes)

WAR Activate warning messages in Syslog (default: Yes)

ERR Activate error messages in Syslog (default: Yes)
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NOTE: To activate the modified network parameters, restart the ServSwitch DKM.

CAUTION: �Consult your system administrator before modifying the network 
parameters. Otherwise, unexpected results and failures can occur in 
combination with the network.

OSD

Select “Configuration > Network” in the main menu.

 

Figure 4-29. Menu Configuration—Network screen.

Table 4-20. Cancel and Save 
selection buttons.

Button Function

Cancel Reject changes

Save Save changes
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Java Tool

Select “System > Network” in the task area.

Figure 4-30. Menu system—network.

4.4.6 Date and Time
Date and Time are set in this menu, based on Simple Network Time Protocol 
(SNTP).

You can access the menu via OSD:

Figure 4-31. OSD icon.
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Table 4-21. Date and time settings.

Field Selection Description

SNTP Client
activated Enable network time server synchronization

deactivated Function not active (default)

SNTP Server Byte Input of the SNTP server IP address (default: 000.000.000.000)

Month 1–12 Enter month

Date 1–31 Enter date

Year 1–99 Enter year

Day 1–7 Enter day of the week

Hours 0–23 Enter hour

Minutes 0–59 Enter minute

Seconds 0–59 Enter second

OSD

Select “Configuration > Date+Time” in the main menu.

 

Figure 4-32. Menu Configuration—Date and Time screen.
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NOTE: Date format according to the English notation.

To configure a time server, proceed as follows:

1. Set the option SNTP Client to Y (Yes).

2. Enter the IP address of your SNTP server in the field SNTP Server.

3. Select your time zone in the field Time Zone.

4. Press the “OK” button to confirm your settings.

5. Restart the matrix. The system time will be now be by the SNTP server.

To set the real time clock without using SNTP, proceed as follows:

1. Set the current date in the field Date.

2. Set the current Day in the field Day.

3. Set the current time in the field Time.

4. Press the “RTC” button to confirm your settings.

Java

Select System > Date and Time in the main menu.

Figure 4-33.
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To configure a time server, proceed as follows:

1. Enable option SNTP.

2. Enter the IP address of your SNTP server in the field SNTP Server.

3. Select your time zone in the field Time Zone.

4. Press the Apply button to confirm your settings.

5. Restart the matrix. The system time will be now provided by the SNTP server.

To set the real time clock without using SNTP, proceed as follows:

1. Set the current date in the field Date and Time.

2. Set the current time in the field Day and Time.

3. Press the Apply button to set the system time.

4. �Option: If you want to receive the time from your currently used computer, 
press the button Get Local Time. 

You can select between the following buttons:

Table 4-22. Cancel and Okay 
selection buttons.

Button Function

Cancel Reject changes

Okay Save changes

4.5 User Settings
4.5.1 User Data
New users and their user settings and permissions are set in this menu.

You have the following options to access the menu:

Figure 4-34. OSD and Java icons.
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You can select between the following settings:

Table 4-23. User data settings.

Field Selection Description

Name Text User name (case-sensitive)

Password Text User password (case-sensitive)

Repeat 
Password

Text Repeat user password (case-sensitive)

FTP
Activated

Access permission via FTP. This setting is necessary for file access from 
the Java tool or any Web browser.

Deactivated Function not active (default)

Power User
activated

• User has rights

• Permission for crosspoint operations

deactivated Function not active (default)

Super User
activated

• Permission for system configuration and all switching operations

• User has administrator rights

• This setting is required for an online connection with the Java tool

deactivated Function not active (default)

Administrator

activated

• Permission for system configuration and all switching operations

• User has administrator rights

• This setting is required for an online connection to the Java tool

deactivated Function not active (default)
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OSD

Select “Configuration > User” in the main menu.

Figure 4-35. Menu Configuration—User screen.

Table 4-24. OSD settings.

Button Function

New Create a new user

Edit Edit an existing user

Delete Delete an existing user

Cancel Reject changes

Save Save changes
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Java Tool

Select “User > User Data” in the task area.

Figure 4-36. Menu User—User Data screen.

Table 4-25. OSD settings.

Button Function

New Create a new user

Delete Delete an existing user

Apply Create a new user account

Cancel Reject changes

To configure user access rights for CPUs, proceed as follows:

1. Select a user in the User list.

2. �By using the right mouse button once on a CPU in one of the respective access 
lists (Full Access, Video Access, and No Access), two lists for selection will 
appear in which the respective CPU can be moved and the access rights can be 
changed.

3. Confirm the configuration by pressing the “Apply” button.
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To create a new user, proceed as follows:

1. Press the “New” button.

2. Select a template of an existing user if applicable (choose template).

3. Press the “OK” button.

4. Set a user name.

5. Set a password.

6. Set general access permissions.

7. Set user permissions for CPU access (paste function).

8. Set user favorites for OSD access.

9. Press the “Apply” button to save the new user settings.

You can select between the following keyboard commands:

Table 4-26. Keyboard commands.

Function Keyboard Command

Add CPU to Full Access list <F>

Add CPU to Video Access list <V>

Add CPU to No Access list <N>

NOTE: �To select all CPUs/targets, highlight one CPU/target, and press Ctrl-A on 
the keyboard.

4.5.2 Favorites List Users
Individual favorites lists of CPUs that have to be switched frequently can be  
created for different users in this menu. A Favorites list can contain up to sixteen  
different CPUs.

The switching of the favorites is done via hotkeys using the keyboard.

You can access the menu in two ways: via OSD or Java.

Figure 4-37. OSD and Java tool icons.
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OSD

Select “Assignments > User Favorites” in the main menu.

Figure 4-38. Menu Assignments – User Favorites.

To create a Favorites list for you own user, proceed as follows:

1. �Select CPUs from the list CPU Devices that have to be moved to the Favorites 
list. By pressing the <a> key, a CPU device will be moved to the Favorites list 
and it will be removed by pressing <r>.

2. �To change the order of the CPU devices within the Favorites list, press the <+> 
and <-> keys.

3. Press the “Save” button to save the settings.
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Java Tool

Select the respective user in the working area of the User menu for the Favorites 
list and open the Favorites tab.

Figure 4-39. Definition – User.

To create a favorite list for any user, proceed as follows:

1. �Select the CPUs in the CPUs Available list to add to the Favorites list (CPU 
assigned). Press the <Ctrl> key to mark more than one CPU device.

2. �Press the “>” button to move the marked CPU devices to the Favorites list. 
Press the >> button, to move the first sixteen CPU devices from the CPU 
Available list to the Favorites list (CPU assigned).

3. �To change the order of marked CPU devices within the Favorites list, press the 
<+> and <-> keys.

4. �To remove marked CPU devices from the Favorites list, press the “<” button. 
Press the “<<” button to remove all CPU devices from the Favorites list.
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4.5.3 User Macros
User macros can be created to switch or disconnect CON units to CPU units, using 
different access rights. The macro commands are created for each user or CON 
separately.

A macro can execute up to 16 switching commands successively.

You will use hotkeys and the function keys <F1>-<F16> to  execute the  
macros.

NOTE: To execute user macros, the user has to be logged in at the matrix.

You can select between the following settings:

Table 4-27. Settings.

Field Selection Description

Function (01–06)

Connect,  
(P1 = CON, P2 = CPU)

Set bidirectional connection from console P1 to CPU P2.

Connect Video,  
(P1 = CON,  P2 = CPU)

Set video connection from console P1 to CPU P2.

Disconnect (P1=CON) Disconnect console P1.

Logout User Logout current user.

Set Real CPU  
(P1 = VCPU, P2 = RCPU)

Assign a virtual CPU to  a real CPU.

Set Virtual CON  
(P1 = RCON, P2 = VCON)

Assign a real console to a virtual console.

Push (P1 = CON)
The individual KVM connection is forwarded to console 
P1 and is changed to a video-only connection.

Push Video (P1 = CON)
The video signal of the current connection (KVM or video 
only) is forwarded to console P1. The individual connec-
tion remains unchanged (KVM or video only).

Get (P1 = CON)

The individual console gets a video-only connection to 
the CPU that is currently connected to console P1. The 
connection of console P1 remains unchanged (KVM or 
video only).

P1 CON or CPU Device Name of CON or CPU device.

P2 CPU or CON Device Name of CON or CPU device.
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You can access the menu in two ways: OSD or Java.

Figure 4-40. OSD and Java icons.

OSD

Select the user that you want to create a user macro for from the “Configuration 
> User Macros” in the main menu.

Figure 4-41. Menu Configuration - User Macros.

To create a macro for the selected user, proceed as follows:

1. Select the key for which a macro has to be created. Choose from 1–16.

2. �Select the respective place on the list (1–16) of the key that has to be set with a 
macro key.

3. �Select the marked place on the list a macro command in the “Macro Data” 
field.



Page 127724-746-5500   |   blackbox.com 

Chapter 4: Configuration

4. �Set the necessary parameters P1 and P2 (for example, CON Devices or CPU 
Devices) for the selected macro command.

5. �Confirm your inputs by pressing the <Enter> key and repeat the process for 
further macro commands, if necessary.

Java-Tool

In the working area of menu “Definition > User,” select the user for which macros 
have to be created and open the tab Macros.

Figure 4-42. Menu Definition - User

To create a macro for the selected user, proceed as follows:

1. Select the Key (1-16) for which a macro has to be created.

2. �Select in the Function the commands that should be part of the macro. Open 
the selection list by double-clicking on the empty fields.

3. �Select the respective parameters for the macro functions (for example,  
corresponding consoles and CPUs) in the P1 and P2 columns.

4. Confirm your inputs by pressing the “Apply” button.
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For an efficient macro configuration, the following context functions are available:

Via right-click on the tab Macros, macros can be assigned to other users by using 
the “Assign Macros to ...” function and can be copied from other users by using 
the “Copy Macros from ....” function.

Via right click on the macro list, you can copy macros of the selected key into the 
cache by using the “Copy Key Macros” function. You can paste the macros from 
the cache into a key by using the “Paste Key Macros” function and you can reset 
all macros of the selected key by using the “Key Macros” function.

4.6 Extender Settings
All extender units are managed in this menu. This also contains the creation of 
new extender units and the deletion of existing extender units.

The extender unit describes the connection of a physical extender to the matrix. 
Every extender board with a direct cable connection to the matrix is recognized  
as an extender unit. Dual-head KVM extenders will be recognized as two  
independent extender units.

NOTE: KVM extenders automatically create extender units inside the matrix.

To access the menu, use OSD or Java:

Figure 4-43. OSD and Java icons.

Table 4-28. OSD settings.

Field Selection Description

ID Text
Numerical value of the extender ID (KVM extenders: ID is  
provided by extender unit [serial no.] and cannot be changed)

Name Text Name of the extender unit

Fixed
Activated Create an extender unit with a fixed port assignment (default)

Deactivated Function not active (default)

Port
1–288 (depending 
on the matrix)

Port number of the extender unit
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OSD

Select “Configuration > EXT Units” in the main menu.

Figure 4-44. Menu Configuration—EXT Units screen.

You can select between the following buttons:

Table 4-29. Extender (EXT) units settings.

Button Function

New Create an extender unit

Edit Edit an existing extender unit

Delete Delete an existing extender unit

Cancel Reject changes

Save Save changes

The settings for the tab OSD Data are described in Section 4.8.2.
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Java Tool

Select “Definition > EXT Units” in the task area.

Figure 4-45. Menu Definition—EXT Units screen.

You can select between the following buttons:

Table 4-30. OSD settings.

Button Function

New Create a new extender unit

Delete Delete an existing unit

Apply Confirm changes of an extender unit

Cancel Reject changes

4.6.1 Creating Flex-Port Extender Units
Extenders with ID function are automatically recognized by the system and cannot 
be created manually. They are used as “Flex-Ports” on the matrix.

NOTE: �The connection of fixed-port extender units (for example, USB 2.0) to a 
Flex-Port can cause unintended results.
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4.6.2 Creating Fixed-Port Extender Units
To create a fixed-port extender unit (for example, USB 2.0), proceed as follows:

1. Press the “New” button.

2. �Select whether a template for a USB 2.0 CON unit (USB CON Unit) or USB 2.0 
CPU unit (USB CPU Unit) should be used.

3. Press the “OK” button.

4. �Determine a port at the matrix that should be used with the USB 2.0 extender 
unit (Fixed Port). As an option, the name of the USB 2.0 extender unit can be 
changed (Name). You need to choose a port that has not already been 
assigned.

5. Press the “Apply” button to save the new extender unit.

NOTE: �Created extender units are always set as fixed-port extenders. These  
configurations are necessary, if you want to switch, for example, USB 2.0 
connections via the matrix.

NOTE: �After creating the Fixed Port for USB 2.0 extenders, the I/O board will need 
to be restarted, otherwise it will not function properly.

4.6.3 Deleting Flex-Port Extender Units
Deleting Flex-Port extender units connected to the matrix is not possible.

4.6.4 Deleting Fixed-Port Extender Units
To delete a fixed-port extender unit (for example, USB 2.0), proceed as follows:

1. �Verify that the fixed-port extender unit to be deleted is currently not assigned 
to a device.

2. Select the fixed-port extender unit to be deleted in the selection list on the left 
side of the menu EXT Units and confirm with the key <Okay>.

3. Press the “Delete” button.

4. Press the “OK” button to confirm the deletion.

NOTE: �To make a fixed port available again for Flex-Port extender units after  
deleting a fixed-port extender unit, restart the I/O board.

4.7 USB 2.0 Extender
This section helps you to configure and use your USB 2.0 extenders. These 
extenders will have to be connected to standard I/O boards in this case. USB 2.0 
extenders can be configured for independent switching or can be assigned to 
already existing KVM extenders.
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You have the following options to configure the extenders:

Figure 4-46.

OSD

• Select Configuration > EXT Units in the main menu.

Figure 4-47. Menu Configuration – EXT Units.

1. �To configure a USB 2.0 extender unit, press the “New” button. An extender 
with an eight-digit ID will be created, starting with digit 9.

2. Assign an appropriate name to the extender in the Name field.

3. �Enter the port number of the matrix physically connected to the USB 2.0 
extender unit into the Port field.

4. �To configure the created extender as a CON Unit, set the USB-CON  
(standalone) option to Y (C#1 in the Input Signals column) and confirm by 
pressing the “OK” button.

5. �To configure the created extender as a CON Unit, set the USB-CPU (standalone) 
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option to Y (C#1 in the Output Signals column) and confirm by pressing the 
“OK” button.

6. �To create an individually switchable Device for the USB 2.0 CON extender, 
select Configuration > CON Devices and press the “New R” button.

Alternatively, you can assign the USB 2.0 CON extender to an already existing 
CON Device. To do this, select the Device and move the USB 2.0 CON extender 
from the EXT available field into the EXT assigned field.

7. Give an appropriate name to the new Device in the Name field.

8. �Repeat steps 6 and 7 for all USB 2.0 CPU extenders in the Configuration > CPU 
Devices menu.

9. �If you use parallel operation within the matrix, set the Release Time in the 
Configuration > Switch menu to 10 seconds or more.

10. �Restart all I/O boards on which USB 2.0 extenders have been configured or 
alternatively restart the matrix.

The USB 2.0 extenders are now configured and can be used.

Java Tool

Select Definition > EXT Units in the task area.

 

Figure 4-48. Menu Definition —EXT Units.
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1. Press the “New” button.

A popup window opens.

2. �Select (Templates) in the selection box, if you want to use a template for a USB 
2.0 CON Unit (USB CON Unit) or a USB 2.0 CPU Unit (USB CPU Unit).

An extender with an eight-digit ID will be created, starting with digit 9.

3. Give an appropriate name to the extender in the Name field.

4. �Enter the port number of the matrix physically connected to the USB 2.0 
extender unit into the Port field.

5. Confirm your settings by pressing the “Apply” button.

6. T�he USB 2.0 CON extenders now has to be either assigned to an existing CON 
Device in the menu Definition > CON Devices or a new CON Device has to be 
created for the assignment by pressing the “New” button.

7. �The USB 2.0 CPU extenders now has to be either assigned to an existing CON 
Device in the Definition > CPU Devices menu or a new CON Device has to be 
created for the assignment by pressing the New button.

8. �If you use parallel operation within the matrix, set the Release Time in the 
Configuration > Switch menu to 10 seconds or more (see Chapter 5.9.6, Page 
138).

9. �Restart all I/O boards on which USB 2.0 extenders have been configured or 
alternatively restart the matrix.

The USB 2.0 extenders are now configured and can be used.

NOTE: �Created extender units are always set as fixed port extenders. This  
configuration is necessary if you want to switch USB 2.0 connections via 
the matrix.

To make a fixed port available again for Flex-Port extender units after deleting a 
fixed port extender unit, restart the I/O board.

4.8 CPU Settings
New CPU devices are configured in this menu including their assignment to 
extenders.

The assignment helps to describe and switch more complex computer  
configurations (for example, Quad-Head with USB 2.0) in the matrix.
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You can access the menu via the OSD or Java icon:

Figure 4-49. OSD and Java icons.

You can select between the following settings:
Table 4-31. CPU settings.

Field Selection Description

ID Text ID of the CPU unit (see Section 4.4.2)

Name Text Name of the CPU device

Virtual Device
Activated Create new CPU device as a virtual one

Deactivated Function not active (default)

Allow Private
Activated Allows switching to the respective CPU device in Private Mode.

Deactivated Function not active (default)

Force Private
Activated Force switching to the respective CPU only in Private Mode.

Deactivated Function not active (default)

Fix Frame
Activated

Force showing a red frame when switching to the respective 
CPU.

Deactivated Function not active (default)



Page 136 724-746-5500   |   blackbox.com 

Chapter 4: Configuration

OSD

Select “Configuration > CPU Units” in the main menu.

Figure 4-50. Menu Configuration—CPU Devices screen.

You can select between the following buttons:

Table 4-32. CPU unit buttons.

Button Function

New R. Create a new real CPU unit

New V. Create a new virtual CPU unit

Edit Edit an existing CPU device

Delete Delete an existing CPU device

Cancel Reject changes

Save Save changes
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Java Tool

Select “Definition > CPU Devices” in the task area.

Figure 4-51. Menu Definition—CPU Devices screen.

You can select between the following buttons:

Table 4-33. CPU devices buttons.

Button Function

New Create a new CPU device

Delete Delete a new CPU device

Apply Confirm a created CPU device

Cancel Reject changes

> Assign selected extender units

>> Assign all available extender units

< Remove the selected extender units

<< Remove all extender units
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You can select between the following keyboard commands:

Table 4-34. Keyboard commands.

Function Keyboard Command

Change assignment number of the extender unit upwards <+>

Change assignment number of the extender unit downwards <->

To create a new CPU device, proceed as follows:

1. Press the “New” button.

2. �Select whether a real CPU (“Create a real CPU”) or a virtual CPU (“Create a  
virtual CPU”) should be created or a template of an existing CPU should be 
used (“Choose template”).

NOTE: A template can be used only if there is at least one existing CPU device.

3. Press the “OK” button.

4. Determine all parameters that are relevant for the CPU.

5. To confirm the new CPU, press the “Apply” button.

To access a new CPU via matrix, an assignment of one or more CPU-type  
extender units is required. Proceed as follows:

1. Select the new CPU in the CPU devices list.

2. Select one or more extenders in the Extender Available list.

3. �Perform the assignment by pressing the “>”button. To assign all available  
extenders to the CPU, press the “>>” button.

    The assignments are displayed in the Extender Assigned list.

4. Confirm the assignment by pressing the “Apply” button.

To remove an extender assignment, proceed as follows:

1. Select a CPU in the CPU Devices list.

2. Select one or more extenders in the Extender Assigned list.

3. �Remove the assignment with the “<” button. To remove all existing  
assignments, press the “<<” button.

4. Confirm the removal with the “Apply” button.
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4.9 Console Settings
You can perform the following console settings:

4.9.1 CON Devices
New CON devices are created in this menu, which include access rights and 
assignment to extenders.

You can access the menu via OSD or Java:

Figure 4-52. OSD and Java icons.

You can select between the following settings:
Table 4-35. CON devices settings.

Field Selection Description

ID Text ID of the CON unit (see Section 4.4.2)

Name Text Name of the CON device

Virtual device
Activated Create new CON device as a virtual one

Deactivated Function not active (default)

Allow User ACL
Activated Allow activation of the User ACL at the local console.

Deactivated Function not active

Force login
Activated Force user login at this CON device

Deactivated Function not active

LOS frame
Activated

If there is a loss of connection, the last picture shown will still be 
displayed and is surrounded by an orange frame.

If you switch to a CPU that does not have a video signal, a blank 
screen will appear surrounded by an orange frame.

Deactivated Function not active (default)

Allow CPU Scan
Activated

Allow a scan mode with an automatic change of the video signal 
for the favorite list (CPU devices) of the respective console or a 
logged in user.

Deactivated Function not active (default).

Force CPU Scan
Activated

Force a scan mode with an automatic change of the video signal 
for the favorite list (CPU devices) of the respective console or 
logged-in user.

Deactivated Function not active (default).

Scan Time 0–99 seconds Retention period until switching to the next CPU device.
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OSD

Select “Configuration > CON Devices” in the main menu.

Figure 4-53. Menu Configuration—CON Devices screen.

You can select between the following buttons:

Table 4-36. CON devices buttons.

Button Function

New R. Create a real console

New V. Create a virtual console

Edit Edit an existing console

Delete Delete an existing console

Cancel Reject changes

Save Save changes



Page 141724-746-5500   |   blackbox.com 

Chapter 4: Configuration

Java Tool

Select “Definition > CON Devices” in the task area.

Figure 4-54. Menu Configuration—CON Devices screen.

Table 4-37. Menu configuration— 
CON devices buttons.

Button Function

New Open a new CON device

Delete Delete a new CON device

Apply Confirm a created CON device

Cancel Reject changes

> Assign selected extender units

>> Assign all available extender units

< Remove the selected extender units

<< Remove all extender units
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You can select between the following keyboard commands:

Table 4-38. Keyboard commands.
Function Keyboard Command

Decrease assignment number of the extender unit <+>

Increase assignment number of the extender unit <->

To create a new console, proceed as follows:

1. Press the “New” button.

2. �Select “Create a real Console” to create a real console or a select “Create a  
virtual Console” to create a virtual console, or select “Choose template” to use 
the template of an existing console.

NOTE: A template can only be used if there is at least one existing CON device.

3. Press the “OK” button.

4. Determine all parameters that are relevant for the console.

5. To confirm a created console, press the “Apply” button.

To run a created CPU via matrix, you need to assign one or more CON units 
(extenders). To place an assignment, proceed as follows:

1. Select the console in the CON devices list to be assigned to an extender.

2. Select the extender in the Extender Available list to be assigned to the CON.

3. �Perform the assignment by pressing the “>” button. To assign all available  
extenders to the console, press the “>>” button. The assignments are displayed 
in the Extender Assigned list.

4. Confirm the assignment by pressing the “Apply” button.

To remove an extender assignment, proceed as follows:

1. Select the console in the CON devices to be modified list.

2. Select the extender(s) in the Extender assigned to be removed list.

3. �Remove the assignment with the “<” button. To remove all existing  
assignments, press the “<<” button.

4. Confirm the changes by pressing the “Apply” button.

To configure the access rights of consoles to CPUs, proceed as follows:



Page 143724-746-5500   |   blackbox.com 

Chapter 4: Configuration

1. Select a console in the CON devices list.

2. Open the “CPU Access Control” tab.

3. �Assign new access rights by using the right mouse button or the respective  
keyboard commands (see below).

4. Confirm the configuration by pressing the “Apply” button.

You can select between the following keyboard commands:

Table 4-39. Keyboard commands.
Function Keyboard Command

Add CPU to Full Access list <F>

Add CPU to Video Access list <V>

Add CPU to No Access list <N>

4.9.2 Mouse and Keyboard
From this menu, you can set the OSD configuration for mouse and keyboard. You 
can access the menu via OSD or Java.

Figure 4-55. OSD and Java icons.

Table 4-40. Mouse and keyboard settings.

Field Selection Description

Horizontal speed 1/x 1–9
Adjusts the horizontal mouse speed:  
1= slow, 9 = fast (default value = 4)

Vertical speed 1/x 1–9
Adjusts the vertical mouse speed:  
1= slow, 9 = fast (default value = 5)

Double-click 100–800
Adjusts the time slot for a double-click 
(default value = 200 ms)

Keyboard layout Region
Set the OSD keyboard layout according 
to the keyboard you are using (default: 
German [DE])

Video Mode
Variable or specific 
resolution

Resolution that is used when opening 
OSD

NOTE: �The mouse and keyboard settings are console specific. You can set them  
separately for every console.
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OSD

Select “Configuration > EXT Units” in the main menu.

Figure 4-56. Menu Configuration—EXT Units screen.

You can select between the following buttons:

Table 4-41. Buttons.

Button Function

Cancel Reject changes

Save Save changes
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Java Tool

Select “Definition > EXT Units” in the task area.

NOTE: Set mouse and keyboard settings using the OSD Data tab.

Figure 4-57. Menu Definition—EXT Units screen.
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4.9.3 Extender OSD
In this menu, the settings for the Extender OSD settings can be adjusted. These 
are local settings that can be made individually for each console.

You can select between the following Extender OSD settings:

Table 4-42. Mouse and keyboard settings.

Field Selection Description

Enable CPU selection
Activated

When executing the key sequence for 
opening the OSD, a selection list for 
switching CPU devices will be displayed 
in the center of the monitor. Pressing 
the button <F7> within the selection 
list opens the standard OSD.

Deactivated Function not active

Enable connection info
Activated Enable Extender OSD (default: Yes)

Deactivated Function not active

Update connection 
info

Activated
Update connection changes during 
fade-in of Extender OSD (default: Yes)

Deactivated Function not active

Display time 0–999 seconds Duration of OSD fade-in (default: 10)

Horizontal position 10 pixels Horizontal OSD position (default: 2)

Vertical position 10 pixels Vertical OSD position (default: 2)

NOTE: When setting the horizontal OSD position, a prefixed minus describes the 
orientation to the right edge of the monitor, for example, -2 means 2 x 10 = 20 
pixels of distance to this edge. When setting a vertical position, a prefixed minus 
describes an orientation to the bottom edge of the monitor.

If the “Update Connections” function is deactivated, the Extender OSD only 
appears when switching via OSD.

You can access the menu in two ways: via OSD or Java.

Figure 4-58. OSD and Java icons.
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OSD

Select “Configuration > EXT Units” in the main menu.

Figure 4-59. Menu Configuration – EXT Units

To change the Extender OSD settings, proceed as follows:

1. �Select the console extender in the list EXT-Units whose Extender OSD settings 
has to be adjusted.

2. �When confirming the selection by pressing the key <Enter>, the respective  
console extender will be enabled for editing.
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Java Tool

Select “Definition > EXT Units” in the task area.

Figure 4-60. Menu Definition – EXT Units.

To change the Extender OSD settings, proceed as follows:

1. �Select the console extender in the list EXT-Units whose Extender OSD settings 
have to be adjusted.

2. Open the “Extender OSD Data” tab.

3. Adjust the desired settings and confirm by pressing the “Apply” button.

4.9.4 Favorite List Consoles
Individual Favorites lists of CPUs that have to be switched frequently can be creat-
ed for different consoles in this menu. A Favorites list can contain up to 16 differ-
ent CPUs. You can switch favorites via hotkeys.

You can access the menu in two ways: via OSD or Java.

Figure 4-61. OSD and Java icons.
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OSD

Select “Assignments > CON Favorites” in the main menu.

Figure 4-62. Menu Assignments – CON Favorites.

To create a Favorites list for your own console, proceed as follows:

1. Select successively the CPUs from the list CPU Devices that have to be moved to 
the Favorites list. Press the <a> key to move a CPU device to the Favorites list. 
Press the <r> key to remove a CPU device from the Favorites list.

2. �To change the order of the CPU devices within the Favorites list, press the <+> 
and <-> keys.

3. Press the “Save” button to save the settings.
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Java Tool

Select the respective user in the working area of the “CON Devices” menu for the 
Favorites list and open the Favorites tab.

Figure 4-63. Menu Definition – CON Devices

To create a Favorites list for any console, proceed as follows:

1. �Select the CPUs in the CPU Available list that should be added to the Favorites 
list (CPU assigned). To mark more than one CPU device at the same time, press 
the <Ctrl> key.

2. �Press the“ >”  button to move the marked CPU devices to the Favorites list. If 
you press the “>>’ button, the first eight CPU devices from the CPU Available 
list will be moved to the Favorites list (CPU assigned).

3. �To change the order of marked CPU devices within the Favorites list, press the 
<+> and <-> keys.

4. �To remove marked CPU devices from the Favorites list, press the “<” button. To 
remove all CPU devices from the Favorites list, press the “<<” button.

4.9.5 Console Macros
In this menu, you can create macro commands for switching, disconnection, or 
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user administration. The macro commands are created for each console separately.

A macro can execute up to 16 switching commands successively.

Execute the macros via “Hotkey” and the <F1>-<F16>  function keys.

You can select between the following settings:

Table 4-43. Console macros settings.

Field Selection Description

Function (01–16)

Connect (P1 = CON, P2 = CPU)
Set bidirectional connection from Console P1 
to CPU P2.

Connect video (P1 = CON, P2 = CPU)
Set video connection from Console P1 to CPU 
P2.

Disconnect  (P1 = CON) Disconnect Console P1.

Logout user Logout current user.

Set Real CPU (P1 = VCPU, P2 = RCPU) Assign a virtual CPU to a real CPU.

Set Virtual CON (P1 = RCON, P2= VCON) Assign a real console to a virtual console.

Push (P1 = CON)
The KVM connection is forwarded to  
Console P1 and is changed to a video-only 
connection.

Push video (P1 = CON)

The video signal of the current connection 
(KVM or video only) is forwarded to  
Console P1. The connection remains 
unchanged (KVM or video-only).

Get (P1 = CON)

The console gets a KVM connection to the 
CPU that is currently connected to Console P1. 
The connection of Console P1 is changed into 
a video-only connection.

Get video (P1 = CON)

The console gets video-only connection to the 
CPU that is currently connected to console P1. 
The connection of Console P1 remains 
unchanged (KVM or video-only).

P1 CON or CPU device Name of CON or CPU device.

P2 CON or CPU device Name of CON or CPU device.



Page 152 724-746-5500   |   blackbox.com 

Chapter 4: Configuration

You can access the menu in two ways: via OSD or Java.

Figure 4-64. OSD and Java icons.

OSD

Via “Configuration > CON Macros” in the main menu, select the console for 
which a console macro has to be created.

Figure 4-65. Menu Configuration - CON Macros

To create a macro for the selected console, proceed as follows:

1. Select the number key (1–16) for which a macro has to be created.

2. �Select the respective place on the list (1–16) of the key that has to be set with a 
macro key.

3. �Select a macro command in the “Macro Data” field from the macro list.

4. �Set the necessary parameters P1 and P2 (for example, CON Devices or CPU 
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Devices) for the selected macro command.

5. �Confirm your inputs by pressing the <Enter> key and repeat the process for 
further macro commands, if necessary.

Java Tool

In the working area of the “Definition > CON Devices” menu, select the console 
for which a console macro has to be created and open the “Macros” tab.

Figure 4-66. Menu Definition - CON Devices

To create a macro for the selected console, proceed as follows:

1. Select the number key (1-16) for which a macro has to be created.

2. �In the “Function” column, select the commands that should be part of the 
macro. Open the selection list by double-clicking on the empty fields.

3. �In the P1 and P2 columns, select the respective parameters for the macro  
functions (for example, corresponding consoles and CPUs).

4. To confirm your inputs, press the “Apply”  button.
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For an efficient macro configuration, the following context functions are available:

• �Right-click on the “Macros” tab to assign macros to other consoles by using the 
“Assign Macros to ...” function. Copy macros from other consoles by using the 
“Copy Macros from ....” section.

•  �Right-click on the macro list to copy macros of the selected key into the cache 
by using the “Copy Key Macros” function. You can paste the macros from the 
cache into a key by using the “Paste Key Macros” function and you can reset 
all macros of the selected key by using the “Reset Key Macros” function.

4.9.6 Parallel Operation
This section explains how to configure the parallel operation of a CPU Device by 
two or more CON Devices. Only one CON Device at a time can control the CPU 
Device, but the CPU device can be taken over exclusively by other CON Devices, 
too. Taking over control is immediately possible or after the controlling CON 
Device’s inactivity timer of the expires. You can use the mouse or keyboard to 
take over control.

NOTE: �To allow a smooth and accurate function of the parallel operation, you 
should use identical mice and keyboards. They should be connected to the 
same USB-HID ports of each CON Unit.

The alternative is using the USB-HID Ghosting (see Chapter 5, Page 203).

You have the following options to configure parallel operation:

Figure 4-67.
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OSD

• Select Configuration > Switch in the main menu.

Figure 4-68. Menu Configuration—Switch.

To configure parallel operation, proceed as follows:

1. Activate the Enable Video Sharing function.

2. Activate the Force Connect function.

3. �Activate the Keyboard Connect function, if taking over control by a keyboard 
event should be possible.

4. �Activate the Mouse Connect function, if taking over control by a keyboard 
movement should be possible.

5. �Define a Release Time of inactivity (0–999 sec.) after which control can be 
taken over.
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Java Tool

• Select System > Switch in the task area.

Figure 4-69. Menu System—Switch.

To configure parallel operation, proceed as follows:

1. Activate the Enable Video Sharing function.

2. Activate the Force Connect function.

3. �Activate the Keyboard Connect function, if taking over control by a keyboard 
event should be possible.

4. �Activate the Mouse Connect function, if taking over control by a keyboard 
movement should be possible.

5. �Define a Release Time of inactivity (0 - 999 sec.) after that control can be taken 
over.

4.9.7 Multi Screen Control
A CON device with several monitors can be configured via USB-HID switching to 
control several connected sources (computer, CPU). To support this feature, you 
will need to have the ACX-GSW license activated.
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Switch between up to four connected sources (computer, CPU) smoothly. Simply 
move the mouse pointer to the next monitor.

Monitors can be arranged in sequence or as a square.

NOTE: �When using sources (computers, CPUs) in multi-head operation (e.g.,  
dual-head), the switching only works manually via keyboard commands. 

NOTE: �To enable Multi-Screen Control, all Extender Units assigned to the CON 
device must be physically connected to the same block of four ports  
consecutively on the I/O board of the matrix.

NOTE: �CON Units that have been already configured for Multi-Screen Control can 
be connected together to other blocks of four ports. In this case, any  
further configuration is not necessary. The functionality will still be 
available.

OSD

Select Assignments > Multi-Screen Control in the main menu.

 

Figure 4-70. Menu Assignments—Multi-Screen Control.
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To configure the Multi-Screen Control, proceed as follows:

1. �In the Arrangement field, select the respective display arrangement that is  
available at the CON Device you want to configure (1 x 4 or 2 x 2).

    �The fields for the configuration of the individual displays will be arranged 
accordingly.

2. �To switch the USB-HID only by using keyboard commands, enable manual 
switching. You can use multi-head consoles.

3. �Ensure that the option “Enabled” is set to “Y” on all used displays to activate 
the display that uses the Multi-Screen Control.

4. �Select one or more control displays within the CON Device by setting the  
function “Control” as “Y” in the respective display field. Control displays are 
referred to the extender units within the Multi-Screen Control that are  
connected to keyboard and mouse.

5. �When using the Owner function, you can determine which control display is 
permitted for USB-HID switching to the different displays. Select that display 
from the list. To set all neighboring control displays to access a display, set the 
function “Owner” to “shared.”

6. �Use the Frame function to configure a red frame that shows the current  
display with mouse control after a selectable timer expires. Activate the frame 
to fade in individually by using a timer >0 seconds.
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Java Tool

Select “Assignment > Multi-Screen Control” in the main menu.

Figure 4-71. Menu Assignment—Multi-Screen Control.

To configure the Multi-Screen Control, proceed as follows:

1. �Select a block of four ports in the working area list that you want to configure  
for Multi-Screen Control. The block of four ports should contain at least one 
CON unit.

2. �Activate the Manual option, and the USB-HID switching will only be allowed by 
using keyboard commands. With manual switching, you can use multi-head  
consoles.

3. �In the Arrangement field, select the display arrangement for the CON device 
you want to configure (1 x 4 or 2 x 2). The fields for the individual display’s 
configuration will be arranged accordingly.

4. �To select one or more control displays within the CON Device, set Control as 
“Y” in the respective display field. Control displays are referred to the extender 
units within the Multi-Screen Control that are connected to keyboard and 
mouse.
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5. �When using the function Owner, you can determine which control display is 
permitted for USB-HID switching to the different displays. Select that display 
from the list. To make a display accessible for all neighboring control displays, 
set the Owner function to shared.

6. �Use the function Frame to configure a red frame that shows the current display 
with mouse control after a selectable timer expires. The frame to fade in can be 
individually activated by using a timer >0 seconds.

4.10 Saving and Loading Configurations

4.10.1 Active Configuration
Use the OSD button to access the menu:

Figure 4-72. OSD button.

Select “Configuration > Save” in the main menu.

By selecting this menu item, the active configuration of the matrix is saved to the 
permanent matrix memory. By default, the last configuration that has been saved 
in this way will be restored after the matrix restarts.

NOTE: �Changing or saving configurations blocks the matrix memory and freezes 
all OSD menus for a few seconds. The switching connections are not 
affected by this freeze.

If you select “Auto Save” within the system settings, it will automatically save the 
configuration periodically.

4.10.2 Saving of Configurations (Internal)
In this menu, the current matrix configuration to predefined storage locations is 
saved. However, it does not replace configuration buffering.

You can access the menu via OSD or Java:

Figure 4-73. OSD and Java icons.
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In Active, the name and detailed information of the current configuration is 
shown. This configuration can be saved now.

In Default and File #1 to File #8, the name and the detailed information of the 
respective saved configurations are shown. You can overwrite these storage  
locations.

The storage location to be overwritten by the current configuration must be 
selected explicitly.

Afterwards, the current configuration will be saved to this storage location and 
will be immediately shown in the menu. The previously saved configuration that 
was saved to this storage location is deleted.

OSD

You can save the created configuration within eight storage locations in the matrix 
(File #1–File #8). You can also save a configuration as the default configuration.

1. Select “Configuration > Save As…” in the main menu.

2. Select the required storage location “(File #1–File #8)” or “Default.”

Figure 4-74. Menu Configuration—Save As screen.
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Java Tool

To save the configuration into the internal matrix memory, proceed as follows:

1. Select “File > Upload to…” in the menu bar.

2. �Enter the IP address of the matrix, your user name, and your password, and 
and confirm the inputs. Press the “Next” button.

3. �Select the storage location where the configuration will be saved (default or  
config01–config08). Press the “OK” button to confirm.

Figure 4-75. Menu File—Upload to screen.

4.10.3 Loading of Configurations (Internal)

Previously saved configurations are loaded in this menu.

You have the following possibilities to load configurations from files:

Figure 4-76. OSD and Java icons.

In Active, the currently loaded configuration is displayed.
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In addition to the default configuration, you can load up to eight further  
configurations.

Select the configuration to be loaded from eight personalizable configurations and 
the default settings.

The selected configuration will be immediately loaded and displayed in the menu 
as “Active.” The previously active configuration is deleted.

OSD

1. Select “Configuration > Open” in the main menu.

2. Select the desired configuration.

3. Load the configuration by pressing the <Enter> key.

Figure 4-77. Menu Configuration—Open screen.
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Java Tool

1. �Select “Administration > Activate Configuration” during on-line mode in the 
task area.

2. Select the required configuration.

3. Load the configuration by pressing the “Activate” button.

Figure 4-78. Menu Administration—Activate Configuration on Switch screen.

4.10.4 Saving of Configurations (External)
Created configurations can be saved as a file on your local computer or laptop for 
backup purposes.

You can access the menu via the Java icon:

Figure 4-79. Java icon.

1. Select “File > Save As” in the menu bar.
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2. �Select the directory of the configuration on your storage medium where it will 
be saved.

NOTE: Configurations are always saved in a file ending “dtc.”

Figure 4-80. Menu File—Save As screen.

4.10.5 Loading of Configurations (External)
Externally saved configurations are opened and activated in this menu.

You have the following possibilities to load configurations from files:

1. �Select “File > Open…” during off-line mode and select the storage location of 
the configuration file that has to be opened.

2. Open the configuration by pressing the “Open” button.

3. �Select “File > Upload to…” in the menu bar to transfer the opened  
configuration to the matrix. Enter the necessary parameters.

4. �Select “Matrix > Connect” in the menu bar to make a connection between the 
matrix and the Java tool. Enter the necessary parameters.

5. �Select “Administration > Activate Configuration” and select the configuration 
to be activated.



Page 166 724-746-5500   |   blackbox.com 

Chapter 4: Configuration

6. Confirm the process with the “Activate” button.

The opened configuration is activated now and can be used.

Figure 4-81. Menu File–Open screen.

4.11 Export and Import Options
The ServSwitch DKM FX offers the possibility to read out available configuration 
lists (extender, CPUs, consoles and users) for exporting and importing again via 
Java tool. You have the following possibilities to handle configuration lists.

Exported configuration lists are always saved in “.csv” format that allows off-line 
editing with common spreadsheet applications.

You can export or import configuration lists via the Java icon:

Figure 4-82. Java icon.
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4.11.1 Export Options
Configuration lists are exported in this menu. To export, proceed as follows:

1. Select “File > Export” in the menu bar.

2. �After opening the menu, select the list to export (Extender, CPU, Console or 
User).

3. Select the storage location for the export file.

4. Confirm the export with the “Finish” button.

Figure 4-83. Menu File–Export screen.

4.11.2 Import Options
Configuration lists are imported in this menu. To import, proceed as follows:

1. Select “File > Import” in the menu bar.

2. �After opening the menu, select the list to import (Extender, CPU, Console or 
User).

3. Select the directory of the list to import.

4. Confirm the import with the “Finish” button.
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Figure 4-84. Menu File–Import screen.

4.12 Matrix Cascading
This simple method of cascading allows a switchable connection between two 
matrices via “Tie Lines.”

The Matrix Cascading does not require Bundle 4. (Bundle 4 is the ACX-CAS 
license.)

This kind of configuration may become necessary if the number of ports in the 
entire system has to be increased or if certain important connections should be 
distributed to several matrices because of redundancy.

The Tie Lines are unidirectional and can only be used in one direction according to 
their configuration. For a bidirectional cascading, you have to configure opposite 
Tie Lines.

To connect Tie Lines to the matrices, you have to create intended Master/Slave 
CON und Master/Slave CPU Devices to be switched within the cascaded  
environment.

You have the following options to configure Matrix Cascading:

Figure 4-85.
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General Preparation

1. �Define a Master Matrix. All further matrices will be configured as Sub Matrices 
in the configuration process.

2. �Ensure that the Tie Lines will only be connected after finishing the configuration.

OSD

• Select Configuration > EXT Units in the main menu of the master matrix.

Figure 4-86. Menu configuration—EXT units.

1. �Press the “New” button. A new Extender Unit will be created that is needed 
for the connection of Tie Lines.

2. Enter an appropriate extender name into the Name field.

3. �Enter a port number into the Port field according to the required connection of 
the Tie Line.

4. �If the Tie Line should be directed from the Sub to the Master, set the Master/
Slave CON option to Y (C#1) in the Input Signals column. If the Tie Line should 
be directed from the Sub to the Master, set the Master/Slave CPU option to Y 
(C#1) in the Output Signals column.
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5. Save your settings by pressing the “Okay” button.

6. �If you have created a Master/Slave CON Unit, select “Configuration > CON 
Devices” in the main menu of the master matrix and press the “New R”  
button.

    A switchable CON Device will be created.

7. �If you have created a Master/Slave CPU Unit, select Configuration > CPU 
Devices in the main menu of the master matrix and press the New R button.

A switchable CPU Device will be created.

8. Enter an appropriate Device name into the Name field.

9. �Assign the previously configured Extender Unit to the newly-created device by 
moving the Extender Unit from the Ext available field into the Ext assigned field 
and save your settings.

10. Repeat steps 1 to 9 for the Sub Matrix.

11. �Select Configuration > System in the main menu of the Sub Matrix and set the 
Sub Matrix option to Y.

     �The OSD of the Sub Matrix will immediately freeze and will be only accessible 
by using the keyboard command <hotkey>, <s>, <o>.

12. �Restart all I/O boards on which any Master/Slave CON or CPU Units have been 
configured or alternatively restart the matrix.

13. �Connect the Tie Lines to the matrices. Ensure that each Master/Slave CON on 
one matrix is connected to Master/Slave CPU on the other matrix to switch 
between two matrices.

The Matrix Casacading is now configured and can be used. Additional Tie Lines 
are configured accordingly.

Java Tool

1. Connect to the Master Matrix and activate the Online Configuration Mode.

2. �Select the menu Definition > EXT Units in the task area and press the New  
button.

A popup window opens.
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Figure 4-87. Menu Definition—EXT Units.

3. �If the Tie Line should be directed from the Sub to the Master, select Master/
Slave CON Unit in the Choose Extender Type selection box.

4. Enter an appropriate extender name into the Name field.

5. �Enter a port number into the Port field according to the required connection of 
the Tie Line.

6. Confirm your settings by pressing the “Apply” button.

7. �If you have created a Master/Slave CON Unit, select “Definition > CON Devices” 
in the task area of the master matrix and press the New button.

   A switchable CON Device will be created.

8. �If you have created a Master/Slave CPU Unit, select “Definition > CPU Devices” 
in the task area of the Master Matrix and press the “New” button.

    A switchable CPU Device will be created.

9. Enter an appropriate extender name into the Name field.

10. �Assign the previously configured Extender Unit to the just-created Device by 
moving the Extender Unit from the Extender available field into the Extender 
assigned field and save your settings by pressing the “Apply” button.

11. Connect to the Sub Matrix and repeat steps 1 to 10.
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12. �Select System > System Data in the task area of the Sub Matrix and activate 
the Sub Matrix option.

     �The OSD of the Sub Matrix will immediately freeze and will be only accessible 
by using the keyboard command <hotkey>, <s>, <o>.

13. �Restart all I/O boards on which any Master/Slave CON or CPU Units have been 
configured or alternatively restart the matrix.

14. �Connect the Tie Lines to the matrices. Ensure that each Master/Slave CON on 
one matrix is connected to Master/Slave CPU in the other matrix in order to 
switch between two matrices.

The Matrix Cascading is now configured and can be used. Additional Tie Lines are 
configured accordingly. The use of cascading is described in Section 4.12. 

4.13 Matrix Grid

In this menu, you can configure a Matrix Grid in order to connect two or more 
matrices. This kind of configuration may become necessary if the number of ports 
in the entire system has to be increased or if certain important connections should 
be distributed to several matrices for redundancy. This setup will require the  
ACX-CAS license to be enabled.

The connections between two matrices have to be established by “Grid Lines” 
that are connected between particular I/O ports as connecting links. The Grid 
Lines can be used bidirectionally and can respectively handle a full access  
connection of a CON Device to a CPU Device.

The number of Grid Lines in the system specifies if a CON Device can be switched 
to a CPU Device in Non-Blocking Access or in Blocking Access and has to be  
separately determined for each Grid environment.

In this case Non-Blocking Access means that a Grid Line for a crossmatrix  
switching operation of a CON Device to a CPU Device is available at any time.

Blocking Access means that for a certain switching operation no Grid Line may be 
available according to the switching status within the Grid. The result will be that 
no cross-matrix switching will be possible.

You have the following options to configure a Matrix Grid:

Figure 4-88.
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Administration of Settings

Within a Matrix Grid, there is a difference between settings that have to be made 
locally for each matrix and settings that can be made globally so that they are 
valid for the whole Matrix Grid.

The settings in the following menus have to be made separately for each matrix or 
within the master matrix in order to affect all matrices in the Grid:

System, Access, Switch, Network, Date + Time, SNMP, Matrix Grid,  
Multi-Screen Control

The settings in the following menus have to be made globally and only once  
within the Matrix Grid:

EXT Units, CPU Devices, CON Devices, User, CON Macros, User Macros, 
CON Favorites, User Favorites, Virtual CPU Devices, Virtual CON Devices.

NOTE: �If global settings are made in the respective menus, they will be  
immediately available on each matrix within the Matrix Grid.

General Preparation

The following requirements have to be fulfilled before starting the Matrix Grid 
configuration:

1. �The Matrix Grid function (Bundle 4) must be activated on all matrices to be 
connected to the Grid by a license key. Bundle 4 is the Black Box part number 
ACX-CAS and will need to be activated.

2. Firmware V3.00 must be installed on all matrices to be connected to the Grid.

3. �All matrices to be connected to the Grid must be within the same TCP/IP  
network.

4. �The port 5556 needed for network communication must not be blocked by a 
firewall.

OSD

To configure a Matrix Grid, proceed as follows. The following configuration steps 
have to be repeated for each matrix separately:

• Select Configuration > System in the main menu.
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Figure 4-89. Menu Configuration—System.

1. �Enter a unique name for each matrix into the Device field. Each name may only 
exist once within the Matrix Grid.

2. �Enter a unique Grid name into the Name field. The Grid name has to be the 
same within all Grid matrices.

3. Select Configuration > Matrix Grid in the main menu.



Page 175724-746-5500   |   blackbox.com 

Chapter 4: Configuration

 

Figure 4-90. Menu Configuration—Matrix Grid.

4. Activate the Enable Matrix Grid function.

5. �Write all device names of the Grid matrices into the Matrix Grid list, starting in 
the left column. Based on the listings, a Grid master will be automatically  
determined for the Matrix Grid. The closer to the top a matrix is listed in the 
matrix Grid list, the more likely the matrix is considered in the automatic master 
selection, provided that certain criteria, such as system availability, are fulfilled.

6. �Activate the single matrices in the Matrix Grid list by enabling the Y (YES)  
function.

7. �Enter the number of chassis ports for each matrix (8, 16, 32, 48, 64, 80, 160 or 
288).

8. Restart all matrices, beginning with the master matrix.

The Matrix Grid can be used now and offers the possibility for a cross-matrix 
switching of CON Devices to CPU Devices.

Java Tool

• To use the Matrix Grid, execute the configuration wizard in the menu System > 
Matrix Grid. It guides you through the configuration of Matrix Grids.
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Figure 4-91. Menu System—Matrix Grid.

4.14 Firmware Update
4.14.1 Matrix Update
The firmware of the matrix can be updated in this menu.

To access the menu, use the Java icon:

Figure 4-92. Java icon.

NOTES: �

To update the matrix, only use computers that are self-sustaining and not  
integrated in the KVM extender/matrix setup.

Ensure that the computer used for the update is not set in standby mode or sleep 
mode during the update.

Save your configuration externally before you start the update.

We do not recommend updating the matrix via a WLAN because this can cause 
files to be half uploaded and a firmware upgrade to fail.  If you have the option to 
use a cross-over CATx cable to perform the update, use this method. 
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Preparation

Follow these steps to prepare for the matrix update:

1. Save the matrix configuration externally.

2. �Open “Extras > Options” in the menu bar and insert the directory from which 
the updated files should be sourced in the ”Firmware Directory” setting.

3. Put all hot spare boards into the matrix.

4. Activate the Syslog function for the monitoring of the update, if unlocked via 
license key.

CAUTION: �Make sure that all USB 2.0 extenders are only connected to the  
provided ports (fixed ports) before you start the matrix update. If you 
don’t, the stability of the update will be compromised.

Performing the Update

Prepare for the matrix update by following these steps:

1. Select “Administration > Update Matrix Firmware” in the task area. 
    �All updateable components of the matrix will be automatically selected and 

highlighted in green after you browse for a valid .TFW file.

 

Figure 4-93. Menu Administration – Update Matrix Firmware.
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2. �To start the update, press the “Update” button in the popup window that 
appears.

3. �Restart the matrix after the update by pressing the “Restart matrix” button in 
the lower part of the working area.

CAUTION: �For a safe start of the matrix, we recommend a cold start (power 
cycle).

4.14.2 Extender Update
In this menu, you can update the firmware of the extenders connected to the 
matrix.

You can access the menu via the Java icon:

Figure 4-94. Java icon.

Preparation

Follow these steps to prepare for the extender update:

1. Save the matrix configuration externally.  
    �Open “Extras > Options” in the menu bar and insert the directory from which 

the update files should be standardly sourced in the “Firmware Directory”  
setting.

2. Connect all hot spare extenders to the matrix.

NOTE: �We do not recommend updating the matrix via a WLAN. This might  
compromise network stability.

Performing the Update in Standard Mode (parallel Update)

1. �Select “Administration > Update EXT Firmware” in the task area. The standard 
mode for the parallel update will be selected by default, and the “Upload 
Firmware” tab will be open.
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Figure 4-95. Menu Administration – Update EXT Firmware.

2. �Before the actual update process, all firmware files that have to be uploaded to 
the respective I/O boards on the extenders will have to be updated. By select-
ing the update files, the I/O boards will be automatically chosen for the upload 
in the “Selected” column and highlighted in green, but only if a newer firm-
ware version is selected.

3. �Start the upload and distribution of the update files by pressing the “Upload” 
button.

NOTE: �By running the upload process, no update files will be installed. The update 
process can be performed at a later time. If there are no selected I/O cards, 
the upload of the update files will be performed in sequence.

4. �A successful upload process will be confirmed by a popup. If you want to 
directly start the actual update process, you will have to confirm this by press-
ing the “Yes” button. You will be immediately forwarded to the “Update 
Firmware” tab.

NOTE: �When updating an identical or an older firmware version as the version 
that is currently installed, the “Force Update” option in the lower part of 
the working area has to be enabled.
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Figure 4-96. Menu Administration – Update EXT Firmware.

5. Start the actual update process by pressing the “Update” button.

NOTE: �Just before the update process, all affected I/O boards will be set to Service 
Mode and retrieved gradually after finishing the respective updates.
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Performing the Update in Expert Mode (Sequential Update)

Follow these steps to prepare for the extender update:

1. �Select “Administration > Update EXT Firmware” and select “Expert Mode” in 
the upper part of the working area. All updateable extenders will be  
automatically selected and highlighted in green after a valid .EFW file has been 
selected using the Browse button.

Figure 4-97. Menu Administration – Update EXT Firmware.

2. �Set the matrix into Service Mode upon request in the popup window or via 
“Matrix > Activate Service Mode” in the menu bar.

During activation, all matrix functions are disabled on the I/O boards on which an 
update is currently performed. An OSD picture indicates the activation of the 
Service Mode and is displayed on all monitors that are connected to the matrix via 
a CON device. Additionally, the Service Mode is indicated by a red tool icon in the 
lower part of the working area.
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FIgure 4-98. OSD View Service Mode.

3. �Start the update by pressing the “Update” button in the lower part of the 
working area.

4. �Quit Service Mode after updating upon request in the popup window or via 
“Matrix > Deactivate Service Mode” in the task area.

5. �In the Java tool via “Administration > Update EXT Firmware” in the “Expert 
Mode Protocol” tab,  verify that updates for all extenders have been installed 
correctly.

4.15 License Management
In this menu, the matrix can be upgraded with new function bundles by using 
license keys.
You will need to purchase the licenses to obtain the additional features. Currently 
the licenses are:

ACX-JAV — Extended switching capabilities with DKM FX Java utility.

ACX-API — API switching feature enabled, also includes ACX-JAV.

ACX-SYS — Enable syslog.

ACX-CAS — Required for every chassis for cascading.
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ACX-GSW — Glide and switch for four receivers to seamlessly control them.

You can access the menu via the Java tool:

Figure 4-99. Java Tool.

To activate a function bundle, follow these steps:

1. Select “Administration > License Management” in the task area.

Figure 4-100. Menu Administration – License Management.

2. �Enter your license key in the working area under “Activate Bundles” in the 
“License Key” field.

3. �To activate the license key, press the “Activate” button. The new functions will 
be immediately enabled; a restart of the matrix will not be necessary.
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5. Operation
You can operate the ServSwitch DKM FX in three different ways:

1. Direct Switching

•  via a keyboard connected to a CON port and the hotkeys

•  by Macro functions on a keyboard (F1-F16)

2. OSD

•  via keyboard/mouse directly connected to the CPU board of the matrix

•  via keyboard/mouse connected to a CON Unit and the OSD

3. External Switching Commands:

•  via an external computer via Java tool (network connection required)

•  via a media control (network or serial connection required)

5.1 Operation via Hotkeys
5.1.1 Direct Switching
The direct switching by hotkeys on a keyboard is the fastest way for a user to 
switch at his console between different CPUs. He can switch video, keyboard and 
mouse, or only video.

Direct Switching of Video, Keyboard, and Mouse

1. �Start Command Mode with the hotkey. For control, the LEDs Shift and Scroll 
flash at the keyboard, if Command Mode is activated.

2. �Enter the index number of the new CPU from the list of favorites and confirm 
with <Enter>. At the same time, the Command Mode is closed and the console 
is connected to the new CPU with complete control.

Example: Switching to favorite CPU 7 with video, keyboard and mouse: 

<left Shift>, <left Shift>, <7>, <Enter>.

NOTE: �For best switching time, use identical mice, keyboards, and monitors.  
This contributes to a smooth and seamless direct switching of the matrix.

Switching in Private Mode

1. �Start Command Mode with the hotkey. The Shift and Scroll LEDs on the  
keyboard flash at the keyboard when command mode is activated.
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2. �Enter the index number of the new CPU from the list of favorites and confirm 
with <left Shift>, <Enter>. The Command Mode closes and the console  
connects to the new CPU with complete control in Private Mode.

Example: Switching to favorite CPU 3 in Private Mode

<left Shift>, <left Shift>, <3>, <left Shift>, <Enter>

Direct Switching of Video

1. �Start Command Mode with the hotkey. For control, the LEDs Shift and Scroll 
flashes at the keyboard, if command mode is activated.

2. �Enter the index number of the new CPU from the list of favorites and confirm 
with <Space>.

At the same time, the Command Mode is closed and the console is connected to 
the new CPU with video only.

Example: Switching to favorite CPU 1 with video only:

<left Shift>, <left Shift>, <1>, <Space>

NOTE: �You can only use the hotkeys to switch to unused and allowed CPUs. 
Hotkeys are only supported if neither “Enable User Login” nor “Enable User 
ACL” is selected and the user is logged in the OSD.

Switch to previous CPU

1. �Start Command Mode using hotkeys. For control, the Shift and Scroll LEDs on 
the keyboard flash when Command Mode is activated.

2. �Press the <p> key on your keyboard. At the same time, the Command Mode 
closes, and the console connects to the previous CPU with complete control.

NOTES: 

If you switch to a previous CPU that was connected with Video Access before, 
you will be connected to this CPU with full KVM access.

You can only switch to unused and allowed CPUs with hotkeys. The “Force 
Connect” and “Force Disconnect” options, as well as the restrictions of the User 
ACL and CON ACL, are taken into account. Hotkeys are only supported if neither 
Enable User Login nor the Enable User ACL is selected and the user is logged in 
the OSD.
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Disconnect current connection

1. �Start Command Mode with the hotkey. When this mode is activated, the Shift 
and Scroll LEDs flash at the keyboard.

2. �Press the <Backspace> key on your keyboard. The Command Mode closes and 
the console disconnects from the previously connected CPU.

5.1.2 Scan Mode
The Scan Mode can show video signals of the different CPUs fast and without 
delay and switch continuously using the hotkey. Switching between two video  
signals can even take place within one frame.

1. �Start command mode with the hotkey. For control, the “Shift” and “Scroll” 
LEDs flash at the keyboard if command mode is activated.

2. �Press the “<Left Shift>” key and hold it down. You can now enter the index 
numbers of the various CPUs from the list of favorites with the keyboard and 
immediately switch to the video signal of the respective CPU after entering the 
index number.

3. Leave Scan Mode by pressing “<Left Shift> + <Esc>.”

NOTE: �For optimal results, use identical resolutions. This contributes to a smooth 
and seamless scan mode function. If the computers/targets are using  
different video resolutions or refresh rates, the switching time is reduced 
because the user monitor will need to sync on the new signal, thus causing 
the monitor to go blank for a few moments.

5.1.3 Function Keys <F1>–<F16>
In Command Mode you can retrieve the Macros 1–16 with the function keys 
<F1>–<F16> of the connected standard keyboard instead of the special macro 
keyboard.

The deposited command sequence for the appropriate function key is executed 
and Command Mode is left immediately.

NOTE: �You don’t need to press the “Enter” key for confirmation of macros.

5.1.4 Addressing of Main and Sub Matrices

The ServSwitch DKM FX can be cascaded in two steps. You can optionally send 
the commands (including opening the OSD) to the main or the sub matrix.

Whenever command mode is activated, you can select by a <m> or a <s>, if all 
the following commands should be handled in the main or in the sub matrix.
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OSD Access

• OSD access to the main matrix:

   <Left Shift>, <Left Shift>, <m> (optional), <o>

• OSD access to the sub matrix:

   <Left Shift>, <Left Shift>, <s>, <o>

Example: Switching to the CPU Port 23 of the sub matrix.

1. �Switching to the CPU port (e.g. 12) of the master matrix that has the  
connection to the sub matrix:

   <Left Shift>, <Left Shift>, <1>, <2>, <Enter>

2. Switching to the CPU Port 23 of the sub matrix:

   <Left Shift>, <Left Shift>, <s>, <2>, <3>, <Enter>

NOTE: �The selected main/sub matrix mode is permanently activated until another 
mode is manually activated. This means that if you select <s> for example, 
all prospective commands will be sent to the sub matrix, but not if the 
Command Mode is left in the meantime.

5.2 KVM Switching
To switch using the ServSwitch DKM FX, use OSD:

Figure 5-1. OSD icon.

OSD

Select “Switch” in the main menu.

NOTE: Press the <F8> key to hide inactive CPU Devices for a better overview.
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Figure 5-2. Menu Switch screen.

The following information is shown in this menu:

Table 5-1 Menu switch.
Field Description

CON device Assigned physical extender unit (CON unit)

CON assigned Virtual CON device that is assigned to the real CON device

CPU connected Currently connected CPU device

CON status Current connection status (CON device)

EXT list LIst of all available physical extender units (CON units)

CPU device Assigned physical extender unit (CPU unit)

CPU assigned Real CPU device that is assigned to a virtual CPU device

CON connected Currenlty connected CON device

CPU status Current connection status (CPU device)

EXT list List of all available extender units (CPU units)
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To switch the console to any available CPU, follow these steps:

1. �Select the CPU device you want to connect to the CON device from the “CPU 
Devices” list.

2. �Confirm with the respective keyboard command according to the desired  
connection type.

You can only switch the CON device to CPU devices that are available in the “CPU 
Devices” list.

NOTE: �Listed CPU devices highlighted in red color are currently connected in 
Private Mode and are blocked by the connected CON device.

Switching via Selection List for CPU Devices

You can use a selection list for KVM switching CPU devices. Proceed as follows:

1. �Activate the option “Enable CPU Selection” in the Configuration menu for 
those consoles where the selection list for CPU devices should be available.

2. �Execute the key sequence for opening the OSD. The selection list immediately 
appears in the preset position of the extender OSD.

NOTE: Press the <F8> key to hide inactive CPU Devices for a better overview.

3. �Execute the desired switching operation by pressing the respective key.

    To not execute a switching operation and access OSD, press the <F7> key.

    To close the selection list, press the <Esc> key.
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Figure 5-3. Example view Selection list CPU Devices.

Activating the automatic Scan Mode for CPU Devices

You can use a scan mode based on the favorite list of each console or user. The 
scan mode allows the matrix to switch in sequence between the CPU Devices in 
the favorite list within a predefined time. All scans are performed in video only 
mode.

To configure the scan mode, go to Chapter 5.8.1.

Activate the scan mode via OSD:

Figure 5-4.

1. Define a favorite list for the CON device or user.

2. Start Command Mode with the hotkey and press <o> to open OSD.

3. �Select one of the CPU devices defined in your favorite list from the CPU  
selection list.

4. �Press the CPU Scanner button to confirm your selection. The scan will start 
automatically.



Page 191724-746-5500   |   blackbox.com 

Chapter 5: Operation

5. �If the Force CPU Scan option is enabled, the scan will automatically start 
switching the CON device to any CPU device from the favorite list without you 
presing the CPU Scanner button.

5.3 Extended Switching
You can perform switching operations via the OSD or Java icon.

Figure 5-5. OSD and Java icons.

OSD

To switch any console to any available CPU, proceed as follows:

Select “Extended Switch” in the main menu.

NOTE: �By pressing the key <F8>, inactive CPU Devices can be hidden to ensure a 
better overview.

Figure 5-6. Menu Extended Switch.
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1. �Select the CON device from the “CON Devices” list that you want to switch to 
a CPU device and open it by pressing “Enter”.

2. �Select the CPU device from the “CPU Devices” list that you want to connect to 
the open CON device.

3. �Confirm with the respective keyboard command according to the desired  
connection type.

Switching operations from the CON device can only be done to CPU devices that 
are available in the “CPU Devices” list.

The following information is shown in this menu:

Table 5-2. Extended switch menu fields.

Field Description

CON device The assigned physical extender unit.

CON assigned Virtual CON device that is assigned to the real CON device.

CPU connected Currently connected CPU device.

CON status Current connection status (CON device).

EXT list List of all available physical extender units (CON units).

CPU device Assigned physical extender unit (CPU unit).

CPU assigned Real CPU device that is assigned to a virtual CPU device.

CON connected Currently connected CON device.

CPU status Current connection status (CPU device).

EXT list List of all available physical extender units (CPU units).
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You can select between the following switching functions:

Table 5-3. Switching functions.

Function Keyboard Command

Set a video-only connection. <Space>

Set a KVM connection. <Enter>

Set a KVM connection in private mode (video sharing disabled). <Shift> + <Enter>

Disconnect the CON device from the CPU device. <Backspace>

Java Tool

You can switch using the Java Tool in two ways:

Option 1: You will need the ACX-JAV license to perform Java extended switching.

Select “Control > Extended Switch” in the task area.

Figure 5-7. Menu Control – Extended Switch.

All connected consoles and the associated CPU connections are shown in columns 
in the working area in this menu.
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NOTE: �Switching operations can only be performed in on-line mode, so you need 
an active network connection between the matrix and the Java Tool.

To set a KVM connection between a console and a CPU, double-click on the  
corresponding selection box in the “Full Access” column and select the requested 
CPU.

To set a video connection between a console and a CPU, double-click on the  
corresponding selection box in the “Video Only” column and select the requested 
CPU.

To set a Private Mode connection between a console and a CPU, double-click on 
the corresponding selection box within the “Private Mode” column and select the 
requested CPU.

NOTE: �CPUs with respective consoles that do not have access rights will not 
appear in the list.

The following symbols are shown in the connection overview:

Table 5-4. Connection overview fields.

Field Description

The CON device is connected via Shared Access with at least one further 
console to the same CPU. The CON device has full access at the moment.

The CON device is connected via Shared Access with at least one further 
console to the same CPU. The CON device has a video access connection  
at the moment.

You can use the following button to perform a switching operation:

Table 5-5. Swiching operation buttons.

Button Function

Send Send switching operations to the matrix.

Reset Disconnect all existing connections within the matrix.

Reload Reload switching status.
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NOTES:

To perform switching operations immediately without confirmation, activate the 
“Auto Send” function in the left lower corner of the working area. Switching 
operations will be done immediately without confirmation when you press the 
“Send” button.

By activating the “Hide Devices w/o Extender Assignment” function in the left 
lower corner of the working area, only CON and CPU devices that are assigned to 
an extender are shown.

Option 2:

Select “Status > Matrix View” in the task area.

Figure 5-8. Menu Status – Matrix View

To perform switching operations between CON and CPU devices, follow these 
steps:

1. Move the mouse cursor to the port that has to be switched.

2. �Hold down the left-mouse button and move the cursor to the port that has to 
be connected to the initial port. The current cursor movement will be displayed 
by a black auxiliary line.
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3. �Release the left-mouse button. A popup to select the available switching type 
(Full Access, Video Access, or Private Mode) will be opened.

4. �Select the desired switching type. The switching operation will be immediately 
executed. At the same time, all extender units that are assigned to the involved 
devices will be switched.

NOTE: �If there is a red cross on a port when switching by using the Matrix View, 
the console to be connected does not have access rights to the respective 
CPU at this port.

To disconnect an existing link between CON and CPU devices, follow these steps:

1. Click on the port that is to be disconnected by using the right mouse button.

2. �Select the “Disconnect” function in the popup that appears. The connected 
ports will be disconnected immediately. At the same time, all further  
connections of the extenders assigned to the involved devices will be  
disconnected.

5.4 CON Switch
KVM extender CON Units connected to a local source (computer, CPU) can be 
locally switched via the matrix. Switching is performed between the local source 
and the KVM connection and can be executed via hotkeys or via OSD.

If you switch to the local source, the KVM connection will be automatically  
disconnected.

NOTE: �When using CON units with the option to connect a local source  
(computer, CPU) in a multi-screen control environment, the local switching 
will be disabled.

You have the following option to switch to the local source:

Figure 5-9.

OSD

• Select Switch in the main menu.
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Figure 5-10. Menu—CON Switch.

To switch to a local source, proceed as follows:

1. �If you are not yet in the Switch menu of the OSD, start Command Mode with 
the hotkey (see Chapter 5.1, Page 53).

2. Press <o> to open OSD.

You will see a list of all available CPUs in the menu.

3. Switch to the CPU in the list that is called Local CPU.

The switching operation to the local source will be immediately performed.

NOTE: �The local source (computer, CPU) will be only shown in the OSD if the 
respective CON Unit includes the option for a local connection.
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Alternatively, there are the following keyboard commands available in order to 
switch to the local source:

Table 5-6. Switching operations.

Keyboard Command Function

 <hotkey>, <k>, <1>, 
<Enter>

Switching to extender connection

<hotkey>, <k>, <2>, 
<Enter>

Switching to extender connection 2 
(only with redundant CON Units)

<hotkey>, <l>, 
<Enter>

Switching to the local source  
(computer, CPU)

5.5 Multi-Screen Control
Using the Multi-Screen function, you can switch the USB-HID signal between  
different statically connected sources (computer, CPU) within a CON Device in two 
different ways: via mouse or via keyboard.

Switching via Mouse

You can switch the USB-HID signal by moving the mouse pointer beyond the 
edge of the current display to a neighboring display according to the  
configuration.

To switch via mouse, proceed as follows:

1. �Move the mouse pointer to the edge of the display which that vertically or  
horizontally borders the neighboring display.

2. �Move the mouse pointer beyond the edge of the display. The mouse pointer 
will appear on the respective position at the target display.

The switching option has been performed and the USB-HID signal will now be 
available at the target display.

Switching via Keyboard

To switch via keyboard:

1. Start Command Mode with the hotkey.

2. �Select the target display by pressing the respective key on the numeric pad of 
the keyboard.

The switching option has been performed and the USB-HID signal will now be 
available at the target display.
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You can select between the following switching operations:

Table 5-7. Switching operations.

Keyboard Command Function

<current hotkey> 
<Num 0>

Switch the USB-HID signal to the display (CON unit with 
keyboard and mouse)

<current hotkey> 
<Num 1>

Switch the USB-HID signal to display #1

<current hotkey> 
<Num 2>

Switch the USB-HID signal to display #2

<current hotkey> 
<Num 3>

Switch the USB-HID signal to display #3

<current hotkey> 
<Num 4>

Switch the USB-HID signal to display #4

5.6 USB 2.0 Switching
Switching USB 2.0 extenders works in a similar way as switching KVM extenders. 
The following scenarios to switch USB 2.0 extenders are possible.

1. �A extender unit with USB 2.0 will be created and assigned to an already  
existing device with existing KVM extender units.

2. �A separate device for the extender unit with USB 2.0 will be created without 
assigning a KVM extender unit to that device. This possibility offers a separate 
switching of the USB 2.0 signal.

NOTES: 

Extended switching includes separate switching of USB 2.0 signals.

When switching USB 2.0 connections you should wait until the process of  
registration of the USB 2.0 devices has been completed before you switch to the 
next CPU (approximately 5–15 seconds). Otherwise the stability of the USB 2.0 
connection can be affected negatively.

5.7 Presets
In this menu, you can create and activate predefined macros to switch the matrix 
without loading a new configuration.

You can access the menu via the Java icon.
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Figure 5-11. Java icon.

Select “Control > Presets” in the task area.

Figure 5-12. Menu Control – Presets.

To create a new switch macro, proceed as follows:

1. �Open a new switch macro by pressing on the “New” symbol in the right  
column of the working area. You’ll be asked if the existing connections should 
be taken over for the new switch macro.

2. �Set the desired switching operations in the corresponding columns (Full Access, 
Video Only or Private Mode) by double-clicking on the respective selection box 
or use the function for a disconnect (Disconnect CPU).

3. �Save the created switch macro by clicking the “Save” symbol in the right  
column of the working area. A save dialog will be opened.

4. �Enter a name or the new switch macro and confirm by pressing the “OK”  
button in the save dialog box.
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5. �Click on a selected switch macro with the right mouse button to create a copy 
of the current switch macro using the option “Save as....”

6. You can delete already saved macros by pressing the “Delete” symbol.

To load a predefined switching, proceed as follows:

1. �Select the switch macro in the right column of the working area that has to be 
loaded.

2. �Activate the selected switch macro by pressing the “Send” button on the  
bottom right of the working area.

NOTES: 

A predefined switch macro can only be activated in on-line mode.

When loading presets, only the switching operations that are compliant with the 
hardware and the configuration of the currently used matrix are taken into 
account.

5.8 Serial Interface

Figure 5-13. OSD icon.

The ServSwitch DKM FX enables you to switch via a serial interface (RS-232).

Detailed information for the serial interface and the corresponding switching  
commands can be found in Chapter 6.

5.9 Power On and Power Down Functions
The ServSwitch DKM FX has the following power on and power down functions: 
restart and reset.

5.10.1 Restart
To perform a restart, use OSD or Java.

Figure 5-14. OSD icon.
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OSD

1. �Select “Configuration > Restart Matrix” or “Restart IO Board” in the main 
menu to restart either the matrix or the I/O boards.

2. �To confirm the selection, press the “OK” button. The matrix and the I/O boards 
will be restarted with the current settings.

Java Tool

Select ”Matrix > Restart Matrix” in the menu bar. The matrix will restart with the 
current settings.

NOTE: �The boot process of the matrix might take longer if there is no physical net-
work connection available.

5.10.2 Factory Reset
Use the OSD to reset the extender:

Figure 5-15. OSD icon.

CAUTION: �If you do a factory reset, all current settings and all configurations 
stored in the matrix will be lost. This also applies to the network 
parameters (reset to DHCP) and the admin password.

NOTE: �If a firmware update has been done since the delivery, the matrix will be 
set to the state defined there.

OSD

1. Select “Configuration > Factory Reset” in the main menu.

2. To confirm the selection, press the “Okay” button.

The ServSwitch DKM FX will be reset to the factory settings.

5.8.3 Power Down
To shut down the system:

1. Select “Configuration > Shut down Matrix” in the main menu.

2. Press “Okay” to confirm the selection.

The matrix will shut down.
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To shut down an I/O board:

1. Select “Configuration > Shut Down I/O Board” in the main menu.

2. Press “Okay” to confirm the selection.

The I/O board will shut down.

5.11 Summary of Keyboard Commands
Use the hotkeys described in the following tables to activate extender and matrix 
functions.

Table 5-8. Extender commands.

Keyboard Command Description

<hotkey> <a> Download the DDC information of the monitor  
connected to the CON unit into the CPU unit.

<hotkey> <k> <1> 
<Enter>

Switch to the KVM connection (only with HDMI CON 
units with available connection for a local source).

<hotkey> <k> <2> 
<Enter>

Switch to the KVM connection 2 (only with HDMI CON 
units with available connection for a local source and a 
redundant interconnection).

<hotkey> <l> <Enter> Switch to the local source (computer, CPU) (only with 
HDMI CON units with available connection for a local 
source).

<hotkey> <h> <w> 
<Enter>

USB-HID ghosting: Write the descriptions of the input 
devices connected to the CON unit into the CPU unit, 
and activate the emulation in the CPU unit.

<hotkey> <h> <e> 
<Enter>

Activate the emulation of already-stored device  
descriptions in the CPU unit.

<hotkey> <h> <d> 
<Enter>

Deactivare the emulation of active device descriptions  
in the CPU unit. The input devices are now passed  
transparently to the source (computer, CPU).

<hotkey> <h> <r> 
<Enter>

Deactivate the emulation of active device descriptions  
in the CPU unit, and delete the descriptions in the CPU 
unit. The input devices are now passed transparently to 
the source (computer, CPU).

Go to the next page for Matrix commands.
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Table 5-9. Matrix commands.

Keyboard Command Description

<hotkey> <o> Open OSD.

<hotkey> <m> <o> Open the master matrix’s OSD in a cascaded  
environment.

<hotkey> <s> <o> Open the sub-matrix’s OSD in a cascaded environment.

<hotkey> <Enter> Set a KVM connection (keyboard, mouse, and video) to 
the selected source (computer, CPU).

<hotkey> <Space> Set a video-only connection to the selected source  
(computer, CPU).

<hotkey> <Left-Shift> 
+ <Enter>

Set a private mode connection to the selected source 
(computer, CPU).

<hotkey> 
<Backspace> 

Close the current connection of the console.

<hotkey> <p> Switch back to the previous connected source (computer, 
CPU) with a KVM connection.

<hotkey> <1>…<16> 
<Enter> (<Space> or 
<Left-Shift> + 
<Enter>)

Switch to a source (computer, CPU) stored in the favorite 
list with a KVM connection (video-only or private mode 
connection).

<hotkey> <F1>…
<F16> 

Execute a predefined macro.

<hotkey> <c> <new 
hotkey key code> 
<Enter>

Change the hotkey according to the predefined hotkey 
table.

<hotkey> <c> <0> 
<new hotkey key> 
<Enter>

Define freely-selectable hotkey.

<hotkey> <f> <new 
hotkey key code> 
<Enter>

Change the hotkey for direct OSD access according to 
the predefined hotkey table.
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Table 5-9 (continued). Matrix commands.

Keyboard Command Description

<hotkey> <f> <0> 
<new hotkey key> 
<Enter>

Define freely selectable hotkey for direct OSD access.

<hotkey> <Num 0> Switch the USB-HID signal to the display (CON unit with 
keyboard and mouse).

<hotkey> <Num 1> Switch USB-HID signals to display #1.

<hotkey> <Num 2> Switch USB-HID signals to display #2.

<hotkey> <Num 3> Switch USB-HID signals to display #3.

<hotkey> <Num 4> Switch USB-HID signals to display #4.

5.12 Serial Interface 

You can switch the ServSwitch via a serial interface (RS-232).

Detailed information for the serial interface and the corresponding switching  
commands are available as an application programming interface (API) can be 
found at www.blackbox.com.
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6. Serial Control

Use the following parameters to control the ServSwitch DKM FX via its serial  
interface.

115.2K, 8, 1, NO

(115.2 kbps, 8 data bits, 1 stop bit, no parity)

Command

<STX>, <command byte (CMD)>, [data bytes (D0…DN)], <ETX>

[ ] = Optional elements

Response

<ACK> , [<ECHO>]

[ ] = Optional elements

<ECHO> reports the ServSwitch DKM FX sequences enabled by a command that 
shows the new switching status of the ServSwitch DKM FX. The echo can be 
used to update user applications and to operate several matrices in parallel.

Parameter Description

Command byte: In the range 0x40 to 0x6F (see the list of allowed commands 
below).

Data bytes: a) To prevent transferring control statements of control commands 
while transferring binary data, the data are divided into low-nibble and high- 
nibble. The data are distributed to the low nibbles of two bytes and provided  
with an offset by 0x60, for example, 0x1F.

=> 0x61 + 0x6F

b) 7-bit data: (0x0 to 0x7F) are provided with an offset by 0x80,  
    e.g. 0000011 => 0x83

c) ASCII data => 0x20 to 0x7E are transmitted unencrypted.
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Special characters: 

	 ACK 	 0x06 
	 NAK 	 0x15 
	 STX 	 0x02 
	 ETX 	 0x03 
	 CR 	 0x0D 
	 ESC 	 0x1B 
	 HTAB 	 0x09 
	 LF 	 0x0A

Sequence of a Data Communication

Table 6-1. Data communication sequence.

ServSwitch KVM DKM FX Control CPU

— 1. Send a command

2. �Acquire a command, process a  
command, block further commands.

—

3. a) Errors occurred: <NAK> 
    b) No errors: <ACK><ECHO> 
    c) Optional: Reply telegram with data

—

—
4. a) Repeat telegram 
    b) Next command 
    c) Receive and process the repeat telegram

NOTE: The serial interface can be blocked while OSD is open.

Switching Functions Telegrams

Table 6-2. Input port’s request for output port.

Bytes Description Coding

1 Control character 0x1B

1 Server indentification 0x5B

1 Command 0x42

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Requested output port (binary, 1…max. ports)
0x01 0x00 (for port 1) to 0x120 0x00 (for port 
288)
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Example:
Input port’s request for output Port 160
0x1B 0x5B 0x42 0x07 0x00 0xA0 0x00

Table 6-3. Return of input port for output port.

Bytes Description Coding

1 Control character 0x1B

1 Server indentification 0x5B

1 Command 0x42

2 Requested output port (binary, 1…max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

2 Assigned input port (binary, 1…max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

Example:
Input Port 17’s return for output Port 160
0x1B 0x5B 0x42 0x09 0x00 0xA0 0x00 0x11x00

Table 6-4. Connection of input port with output port.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x43

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested output port (binary, 1…max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

2 Assigned input port (binary, 1…max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)
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Example:
Connection of input Port 17 with output Port 160
0x1B 0x5B 0x43 0x09 0x00 0xA0 0x00 0x11 0x00

Table 6-5. Request of input port for output port with a fixed total port number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x44

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2
Number of output ports  (binary, 1…max. 
ports)

0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 287)

2 Requested output port (binary, 1…max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

Example:

Request of input port for output Port 25 with a total port number of 160

0x1B 0x5B 0x44 0x09 0x00 0xA0 0x00 0x19 0x00

Table 6-6. Return of input port for output port with a fixed port number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x44

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Number of output ports  (binary, 1…max. 288 
ports)

0x01 0x00 (for Port 1) to 0x120 0x00 (for 287 
ports)

Example:

Return of input Port 17 for output Port 25 with a total port number of 160.

0x1B 0x5D 0x44 0x09 0x00 0xA0 0x00 0x19 0x00 0x11 0x00
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Table 6-7. Connection of input port with output port  
with a fixed total port number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x45

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Number of output ports  (binary, 1…max. 
2887ports)

0x01 0x00 (for Port 1) to 0x120 0x00 (for 287 
ports)

Example:

Connection of input Port 17 with output Port 25 with a total port number of 160

0x1B 0x5B 0x45 0x07 0x00 0xA0 0x00 0x19 0x00 0x11 0x00

Table 6-8. Request of switching matrix.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x46

Table 6-9. Return of the switching matrix (input port for all output ports).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x46

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Input port whose signal is sent to output port 
OutPort (n)

0x01 0x00 (for Port 1) to 0x120 0x00 (for 288 
ports)

Example:

Return input Port 17 for all output ports

0x1B 0x5D 0x46 0x07 0x00 0x11 0x00
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Table 6-10. Request of CPU (input) for CON (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x46

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Requested output console
0x01 0x00 (for Console 1) to 0x11F 0x00  
(for Console 287)

Example:

Request of CPU (input) for Console 23

0x1B 0x5B 0x47 0x07 0x00 0x17 0x00

Table 6-11. Return of CPU (input) for CON (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x47

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested output console
0x01 0x00 (for Console 1) to 0x11F 0x00 (Console 
287)

2 Requested input CPU 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 287)

Example:

Return of CPU 34 for Console 23

0x1B 0x5D 0x47 0x09 0x00 0x17 0x00 0x22 0x00
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Table 6-12. Connection of CPU (input) with CON (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x48

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested console
0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
Console 287)

2 Requested CPU
0x01 0x00 (for CPU 1) to 0x11F 0x00 (for  
CPU 287)

Example:

Connection of CPU 43 with Console 23

0x1B 0x5B 0x48 0x09 0x00 0x17 0x00 0x2B 0x00

Table 6-13. Request of CPU (input) for CON (output)  
with a fixed console number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x49

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2
Total number of consoles (binary, 1…max. 
CONs)

0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
287 Consoles)

2 Requested consoles
0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
Console 287)

Example:

Request of CPU (input) for Console 23 with 50 consoles in total

0x1B 0x5B 0x49 0x09 0x00 0x32 0x00 0x17 0x00
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Table 6-14. Return of CPU (input) for CON (output)  
with a fixed console number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5D

1 Command 0x49

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Total number of consoles (binary, 1…max. 
CONs)

0x01 0x00 (for console 1) to 0x11F 0x00 (for  
287 consoles)

Example:

Return of CPU 43 for Console 23 with 50 consoles in total

0x1B 0x5D 0x49 0x07 0x00 0x32 0x00 0x17 0x00 0x2B 0x00

Table 6-15. Connection of CPU (input) for CON (output)  
with a fixed console number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x50

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Total number of consoles (binary, 1…max. 
CONs)

0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
287 consoles)

Example:

Connection of 43 with Console 23 with 50 consoles total

0x1B -x5B 0x50 0x07 0x00 0x32 0x00 0x17 0x00 0x2B 0x00
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Table 6-16. Request of CON (input) for CPU (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x51

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Total number of consoles (binary, 1…max. 
CONs)

0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 
287)

Example:

Request of CON (input) for CPU 23

0x1B 0x5B 0x51 0x07 0x00 0x17 0x00

Table 6-17. Return of CON (input) for CPU (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5D

1 Command 0x51

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested output CPU 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 287)

2 Requested input console
0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
console 287)

Example:

Request of Console 23 for CPU 23

0x1B 0x5D 0x09 0x00 0x2B 0x00 0x17 0x00
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Table 6-18. Connection of CON (input) with CPU (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x52

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested output CPU 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 287)

2 Requested input console
0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
Console 287)

Example: 
Connection of Console 23 with CPU 43

0x1B 0x5B 0x52 0x09 0x00 0x2B 0x00 0x17 0x00

Table 6-19.  Request CON (input) for CPU (output) with a fixed CPU number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x52

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Total number of CPUs 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for 159 CPUs)

2
Requested output for CPU (binary, 1…max. 
CPUs)

0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
Console 287)

Example:

Request for CPU 43 with 50 CPUs in total

0x1B 0x5B 0x53 0x09 0x00 0x32 0x00 0x2B 0x00
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Table 6-20.  Return of CON (Input) for CPU (Output) with a fixed CPU number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5D

1 Command 0x53

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Total number of CPUs 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)

Example:

Return of Console 23 for CPU 43 with 50 CPUs in total

0x1B 0x5D 0x53 0x07 0x00 0x32 0x00 0x2B 0x00 0x17 0x00

Table 6-21. Connection of CON (input) with CPU (output)  
with a fixed total CPU number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x54

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Total number of CPUs 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)

Example:

Connection of Console 23 with CPU 43 with 50 CPUs in total

0x1B 0x5B 0x54 0x07 0x00 0x32 0x00 0x2B 0x00 0x17 0x00
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Table 6-22. Connection of CON (input) with CPU (output)  
and CPU (input) with CON (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x55

2
Total length of telegram  
(9 bytes, binary)

0x09 0x00

2 Requested CPU 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)

2 Requested console 0x01 0x00 (for Console 1to 0x11F 0x00 (for Console 287)

Example:

Connection of Console 23 (input) with CPU 43 (output)

0x1B 0x5B 0x55 0x09 0x00 0x2B 0x00 0x17 0x00

Table 6-23. Connection of CON (input) with CPU (output)  
and CPU (input) with CON (output) with a fixed CPU number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x56

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Total number of CPUs 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)

Example:

Connection of Console 23 with CPU 43 and Console 24 with CPU 44 with 50 
existing CPUs

0x1B 0x5B 0x56 0x07 0x00 0x32 0x00 0x2B 0x00 0x17 0x00 0x2C 0x00

0x18 0x00



Page 218 724-746-5500   |   blackbox.com 

Chapter 7: Troubleshooting	

7. Troubleshooting

Tables 7-1 through 7-7 provide support for problems with the ServSwitch DKM FX 
matrix. This help assumes a functional extender route. Before troubleshooting, 
make sure your extenders work over a point-to-point connection. This can be  
supported by the using a CATx or fiber coupler.

7.1 External Failure

Table 7-1. External failure.

Problem Possible Cause Solution

ServSwitch DKM FX cannot be started Fuse at the standard appliance outlet is out Check fuse

7.2 Video Interference
Table 7-2. Video interference.

Problem Possible Cause Solution

Opening the OSD is not possible
No OSD jumper set Set Jumper 11 on the CON unit

Switch set up as sub-master Try using hotkeys L-shift, L-shift, S, O

Incorrect video display Cable connection disturbed
Check the connection, length, and 
quality of the interconnection cable to 
the units

7.3 Fans Malfunction

Table 7-3. Fans malfunction.

Problem Possible Cause Solution

Fans do not run; LED OK is on Fans are defective
Contact Black Box Technical Support at 724-
746-5500 or info@blackbox.com

Fans do not run; LED OK is off Power supply Check power supply and power connections
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7.4 Power Supply Units Malfunction

Table 7-4. Power supply units malfunction.

Problem Possible Cause Solution

ServSwitch DKM FX  
cannot be started

No power supply is available
Check that cables for the power supply 
are connected correctly

Power supply units are not 
switched on

Check the slide to switch on the power 
supply units

7.5 Network Error

Table 7-5. Network error.

Problem Possible Cause Solution

Network settings are not 
resumed after editing

ServSwitch DKM FX restart is not yet 
completed

Restart the unit

CPU board was not properly installed
Pull black tab outward on 
CPU board. Wait 30 seconds, 
then push back in.

7.6 ServSwitch DKM FX Failure

Table 7-6. ServSwitch DKM FX failure.

Problem Possible Cause Solution

Serial control is impossible  
or restricted

CPU and ServSwitch DKM FX 
are running at a different baud 
rate

Adapt the baud rate in the 
ServSwitch DKM FX and in the 
CPU

Serial control via the RJ-45 
port is not possible

Wrong network cable Use a cross-pinned network cable

Port definitions as USB 2.0 
invalid

ServSwitch DKM FX restart not 
yet completed

Restart the ServSwitch DKM FX



Page 220 724-746-5500   |   blackbox.com 

Chapter 7: Troubleshooting	

7.7 Blank Screen

1   2         3

1  2         3 3

Figure 7-1. LEDs on the ServSwitch DKM FX.

Table 7-7. LED indications.

Problem Possible Cause Solution

Monitor remains dark after 
switching operation

Switching to a CPU port 
without active source 
(computer, CPU)

Connect the computer or CPU

Connection of a console 
with a CON port or  
connection of a CPU to a 
CPU port not established 
correctly

Check CON and CPU port connections at the 
ServSwitch DKM FX

LED 1 on or LED 2 off
Connections of the CON 
unit, ServSwitch DKM FX, 
and the CPU unit

Check the cables and connectors (no cable, 
cable break, CPU/CON unit off-line, CPU/CON 
unit connected to the wrong port

LED 3 off Power supply
Check the power supply units and connection 
to the power network

7.8 Contacting Black Box
If you determine that your ServSwitch DKM FX is malfunctioning, do not attempt 
to alter or repair the unit. It contains no user-serviceable parts. Contact Black Box 
Technical Support at 724-746-5500 or info@blackbox.com.

Before you do, make a record of the history of the problem. We will be able to 
provide more efficient and accurate assistance if you have a complete description, 
including:
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• the nature and duration of the problem.

• when the problem occurs.

• the components involved in the problem.

• �any particular application that, when used, appears to create the problem or 
make it worse.

7.9 Shipping and Packaging
If you need to transport or ship your ServSwitch DKM FX:

• Package it carefully. We recommend that you use the original container.

• �If you are returning the unit, make sure you include everything you received 
with it. Before you ship for return or repair, contact Black Box to get a Return 
Authorization (RA) number.



Page 222 724-746-5500   |   blackbox.com 

Appendix: Glossary

Appendix. Glossary

The following terms are commonly used in this guide or in video and KVM  
technology:

AES/EBU — Digital audio standard officially known as AES3, used for carrying 
digital audio signals between devices.

CATx — Any CAT5e (CAT6, CAT7) cable.

CGA — The Color Graphics Adapter (CGA) is an old analog graphics standard  
with up to 16 displayable colors and a maximum resolution of 640 x 400 pixels.

Component Video — The Component Video (YPbPr) is a high-quality video  
standard that consists of three independently and separately transmittable video 
signals, the luminance signal, and two color difference signals.

Composite Video — The Composite Video is also called FBAS and it is part of 
the PAL TV standard.

CON Unit — Component of a ServSwitch DKM FX or media extender that  
connects to the console (monitor[s], keyboard and mouse; optionally also with 
USB 2.0 devices).

CPU Unit — Component of a ServSwitch DKM FX or media extender that  
connects to a source (computer, CPU).

DDC — The Display Data Channel (DDC) is a serial communication interface 
between a monitor and a source (computer, CPU). It enables data exchange via  
monitor cable and automatic installation and configuration of a monitor driver  
by the operating system.

Dual Access — A system that operates a source (computer, CPU) from two  
consoles.

Dual-Head — A system with two video connections.

Dual Link — A DVI-D interface for resolutions up to 2560 x 2048 by signal  
transmission of up to 330 MPixel/s (24-bit).

DVI — Digital video standard, introduced by the Digital Display Working Group 
(http://www.ddwg.org). See also Single Link and Dual Link. The signals have 
TMDS level.

DVI-I — A combined signal (digital and analog) that allows running a VGA  
monitor at a DVI-I port—in contrast to DVI-D (see DVI).
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Fiber — Single-mode or multimode fiber cables.

EGA — The Enhanced Graphics Adapter (EGA) is an old analog graphics  
standard, introduced by IBM® in 1984. It uses a DB9 connector.

FBAS — The analog color video baseband signal (FBAS) is also called Composite 
Video and it is part of the PAL TV standard.

Console — Keyboard, mouse, and monitor.

KVM — Keyboard, video, and mouse.

Mini-XLR — Industrial standard for electrical plug connections (3-pole) for the 
transmission of digital audio and control signals.

Multimode — 62.5-μ or 50-μ fiber cable.

OSD — An OSD (on-screen display) is used to display information or to operate a 
device.

Quad-Head — A system with four video connections.

RCA (Cinch) — A non-standardized plug connection that transmits electrical 
audio and video signals, especially with coaxial cables.

SFP — SFPs (Small Form Factor Pluggables) are pluggable interface modules for 
Gigabit connections. SFP modules are available for CATx and fiber interconnect 
cables.

S/PDIF — A digital audio interconnect used in consumer audio equipment over 
relatively short distances.

Single-Head — A system with one video connection.

Single Link — A DVI-D interface for resolutions up to 1920 x 1200 by signal 
transmission of up to 165 MPixel/s (24-bit). Alternative frequencies are Full HD 
(1080p), 2K HD (2048 x 1080), and 2048 x 1152.

Single-Mode — 9μ fiber cable.

S-Video (Y/C) — The S-Video (Y/C) is a video format that transmits luminance 
and chrominance signals separately. It has a higher-quality standard than FBAS.

TOSLINK® — Standardized fiber connection system for digital transmission of 
audio signals (F05 plug connection).

Triple-Head — A system with three video connections.
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USB HID — USB HID devices (human interface devices) allow for data input. You 
don’t need a special driver during installation; “New USB-HID device found” is 
reported. Typical HID devices include keyboards, mice, graphics tablets, and  
touchscreens. Storage, video, and audio devices are not HID.

VGA — Video Graphics Array (VGA) is a computer graphics standard with a  
typical resolution of 640 x 480 pixels and up to 262,144 colors. Its is preceded by 
the graphics standards MDA, CGA and EGA.

A.1 Matrix-Specific Glossary
Auto Disconnect — Matrix function that allows an automatic disconnect 
between a console and a CPU, if the OSD is opened via this console.

Auto Logout — Matrix function that describes the duration of inactivity after the 
user has been logged out from the OSD at this console.

CON Device — Logical term that summarizes several physical extenders to switch 
more complex console systems via matrix.

CON Timeout — Matrix function that allows an automatic disconnect of the 
console from the connected CPU after a predefined time.

Console ACL — Console ACL (Access Control List) is a list that shows the respec-
tive switching rights for the various consoles.

CPU Auto Connect — Matrix function that allows an automatic connection  
establishment between the own console and a random available CPU.

CPU Device — Logical term that summarizes several physical extenders to switch 
more complex CPU systems via matrix.

CPU Timeout — Matrix function that allows the user to disconnect after a  
predefined period of time of inactivity from the respective CPU.

EXT Unit — Part or extender board of a CON or CPU unit with a connection to 
the matrix. A CON or CPU unit can consist of several EXT devices.

Force Connect — Matrix function that allows a user to switch with his own  
console to a CPU that is already used. This enables the user to take keyboard and 
mouse control. The connected console loses K/M control but keeps video.

Force Disconnect — Matrix function that allows to switch with the console to a 
CPU that is already used. This enables the user to take KVM control. The  
connected console loses complete KVM control.

Java Tool — Java based control and configuration tool for the ServSwitch DKM 
FX matrix.
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Keyboard Connect — Matrix function that allows taking over the keyboard  
control of an inactive console.

Macro Keys — Programmable keys that string together commands to the matrix.

Mouse Connect — Matrix function that enables a user to control an inactive 
console’s mouse.

Non-Blocking-Access — Matrix configuration in which no user can be disturbed  
by an activity of another user.

OSD Timeout — Matrix function that closes the OSD automatically after a  
predefined period of time of inactivity.

Release Time — Matrix function that enables a console connected to the same 
CPU to release the K/M control after a predefined time.

Tie-Line — Communication connection to and between extension modules in a 
network environment.

User ACL — User ACL (Access Control List) is a list that shows the respective 
switching rights for the various users.

Video Sharing — Matrix function that enables switching from a user’s own  
console to any CPU with video.
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